# CVE-2026-91991: Tornado before 6.5.8 Cookie Attribute Injection via Capitalized kwargs

> Attackers can inject arbitrary cookie attributes via capitalized kwargs in Tornado, bypassing security validation and modifying cookie settings.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** BELL-CVE-2026-91991, CLEANSTART-2026-FR34222, CLEANSTART-2026-MS68027, CLEANSTART-2026-NF84390, CLEANSTART-2026-OZ84157, CLEANSTART-2026-RK84502, DEBIAN-CVE-2026-91991, ECHO-b37c-7c95-fabf, GHSA-jj9x-pjq2-f55m, GHSA-wwv5-g3v4-889x, MINI-37m9-mmr2-hpqv, MINI-475w-g7hr-vc2r, MINI-48g8-63f7-2hh3, MINI-78x6-39mx-fcvv, MINI-7w9h-rfmg-8hfp, MINI-8fcv-x33q-q2x8, MINI-8pqw-4f4q-4292, MINI-8pxg-wqx5-76ww, MINI-9jvg-q396-qv72, MINI-c9hj-rh9m-hcxv, MINI-cwg8-5vhc-hpwq, MINI-gqhm-6vm3-9xj8, MINI-hgrf-hvw4-f6cr, MINI-hrhq-m4pp-g64v, MINI-m84q-wwmp-6mjm, MINI-qcwh-qh3w-m782, MINI-qgr8-vxw9-957r, MINI-r2fx-2jr5-5j94, MINI-rxcm-gm76-3fmc, MINI-v5gx-f627-j4pm, MINI-w9h5-vx53-m83g, MINI-x378-ccgc-497x, MINI-xgf5-xqf8-v3v5, MINI-xhx2-38r9-cc38, UBUNTU-CVE-2026-91991

## What is CVE-2026-91991?

CVE-2026-91991 is a medium-severity vulnerability in tornadoweb tornado, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Tornado before 6.5.8 contains an incomplete fix for cookie attribute injection that allows attackers to inject arbitrary cookie attributes by passing capitalized or legacy keyword arguments to set_cookie. Attackers can embed semicolon-delimited data in capitalized parameters like Domain, Path, or SameSite to bypass validation and modify cookie security attributes.

Weakness: CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2026-91991?

2 open source packages ship an affected version, including tornado.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tornado` | PyPI | From 6.5.5 | 6.5.8 |
| `tornado` | PyPI | From 6.5.5 | 6.5.8 |

## How do I fix CVE-2026-91991?

Upgrade tornado to 6.5.8 or later.

## Is CVE-2026-91991 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-91991 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-91991 and fix it if it is affected.

What it is: CVE-2026-91991 is a medium-severity vulnerability in tornadoweb tornado, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-91991 exists.

Affected packages and fixed versions:
- tornado (PyPI): affected from 6.5.5; fixed in 6.5.8
- tornado (PyPI): affected from 6.5.5; fixed in 6.5.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-91991/ (Markdown: https://insights.sbomify.com/CVE-2026-91991/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-91991
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-91991
- OSV: https://osv.dev/vulnerability/CVE-2026-91991

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-91991/
Summaries are generated and may contain mistakes; the official description above is the record.
