{"answers":{"affected":"2 open source packages ship an affected version, including tornado.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-91992 exists.","fix":"Upgrade tornado to 6.5.7 or later.","what":"CVE-2026-91992 is a high-severity vulnerability in tornadoweb tornado, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-91992 and fix it if it is affected.\n\nWhat it is: CVE-2026-91992 is a high-severity vulnerability in tornadoweb tornado, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-91992 exists.\n\nAffected packages and fixed versions:\n- tornado (PyPI): affected all versions; fixed in 6.5.7\n- tornado (PyPI): affected all versions; fixed in 6.5.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-91992/ (Markdown: https://insights.sbomify.com/CVE-2026-91992/index.md)","id":"CVE-2026-91992","markdown":"https://insights.sbomify.com/CVE-2026-91992/index.md","name":"CVE-2026-91992","record":{"aliases":["AZL-103098","BELL-CVE-2026-91992","CLEANSTART-2026-QY66833","DEBIAN-CVE-2026-91992","ECHO-fb4d-7ed6-e752","GHSA-jqv5-7x9v-7j83","GHSA-pw6j-qg29-8w7f","MINI-28gw-38q2-4jhh","MINI-4q85-h94j-qv34","MINI-5qvq-874w-rw2p","MINI-6hjf-9xhf-342v","MINI-gxc3-jwjh-9p5q","MINI-jpqp-hxr7-3rrc","MINI-mhw3-4x87-rgpm","MINI-vhf3-895m-r9w5","MINI-w239-w9g9-vr34","MINI-xcc5-pr94-62cw","ROOT-APP-PYPI-GHSA-pw6j-qg29-8w7f","UBUNTU-CVE-2026-91992"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python web framework","requires_auth":"none","summary":"Attackers can leak sensitive credentials like TLS certificates or proxy auth via handle reuse in Tornado's CurlAsyncHTTPClient.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Tornado before 6.5.7 contains a credential leak vulnerability in CurlAsyncHTTPClient where pycurl handles are reused across requests without proper state clearing. Attackers can obtain sensitive credentials by issuing requests through the same client instance, allowing TLS certificates or proxy authentication to persist across unintended requests.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Tornado before 6.5.7 Credential Leak via Handle Reuse","id":"CVE-2026-91992","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Jpom through 2.11.12 Workspace Isolation Bypass via /build/branch-list","id":"CVE-2026-91993"},"packages":[{"ecosystem":"PyPI","fixed":["6.5.7"],"introduced":["0"],"last_affected":[],"package":"tornado","purl":null,"source":"GHSA-pw6j-qg29-8w7f"},{"ecosystem":"PyPI","fixed":["6.5.7"],"introduced":["0"],"last_affected":[],"package":"tornado","purl":"pkg:pypi/tornado","source":"GHSA-pw6j-qg29-8w7f"}],"prev":{"headline":"Tornado before 6.5.8 Cookie Attribute Injection via Capitalized kwargs","id":"CVE-2026-91991"},"products":["tornado"],"published":"2026-09-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-17","vendors":["tornadoweb"]},"summary":"Attackers can leak sensitive credentials like TLS certificates or proxy auth via handle reuse in Tornado's CurlAsyncHTTPClient.","url":"https://insights.sbomify.com/CVE-2026-91992/"}