{"answers":{"affected":"2 open source packages ship an affected version, including adm-zip.","exploited":"There is no known exploitation of CVE-2026-92000 in the wild and no public exploit code.","fix":"Upgrade adm-zip to 0.6.1 or later.","what":"CVE-2026-92000 is a high-severity denial of service vulnerability in cthackers adm-zip, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-92000 and fix it if it is affected.\n\nWhat it is: CVE-2026-92000 is a high-severity denial of service vulnerability in cthackers adm-zip, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-92000 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- adm-zip (npm): affected all versions; fixed in 0.6.1\n- adm-zip (npm): affected all versions; fixed in 0.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-92000/ (Markdown: https://insights.sbomify.com/CVE-2026-92000/index.md)","id":"CVE-2026-92000","markdown":"https://insights.sbomify.com/CVE-2026-92000/index.md","name":"CVE-2026-92000","record":{"aliases":["CLEANSTART-2026-LH18795","CLSA-2026-1790718594","ECHO-7670-6e90-963d","GHSA-ffxc-vw9f-x2cp","GHSA-rcw4-f5rp-g42v","MINI-34hf-xvr3-qjch","MINI-5wj3-wmh5-fhf9","MINI-5wxv-rfm6-g24v","MINI-5xf7-c75g-m4rj","MINI-9w4g-429h-xf2g","MINI-fvv7-vxvh-2368","MINI-j9v9-g3jx-8fm7","MINI-jvwh-q9qw-wpjr","MINI-pv5c-2mj9-gc8q","MINI-qc4f-fmg4-7ccv","MINI-rjvc-qj9r-6395","MINI-v484-m42w-3vmj","MINI-vr3h-27g6-xmh5","MINI-x9jm-f9p3-wg8v","ROOT-APP-NPM-GHSA-rcw4-f5rp-g42v"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript ZIP library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using adm-zip by submitting malicious ZIP archives that trigger memory exhaustion.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-409","name":"Improper Handling of Highly Compressed Data (Data Amplification)"}],"description":"adm-zip versions 0.5.14 through 0.6.0 fail to apply zlib decompression output limits when ZIP entries declare zero uncompressed size. Attackers can craft malicious ZIP archives with highly compressible entries declaring zero size to exhaust memory and cause denial of service.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"adm-zip 0.5.14 through 0.6.0 Denial of Service via Zero Declared Uncompressed Size","id":"CVE-2026-92000","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":6,"next":{"headline":"Apache Sling XSS: Missing parser resource limits","id":"CVE-2026-92001"},"packages":[{"ecosystem":"npm","fixed":["0.6.1"],"introduced":["0"],"last_affected":[],"package":"adm-zip","purl":null,"source":"GHSA-rcw4-f5rp-g42v"},{"ecosystem":"npm","fixed":["0.6.1"],"introduced":["0"],"last_affected":[],"package":"adm-zip","purl":"pkg:npm/adm-zip","source":"GHSA-rcw4-f5rp-g42v"}],"prev":{"headline":"Apache Sling XSS: Improper escaping in the XSS Webconsole plugin","id":"CVE-2026-91999"},"products":["adm-zip"],"published":"2026-09-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-24","vendors":["cthackers"]},"summary":"Attackers can cause denial of service in applications using adm-zip by submitting malicious ZIP archives that trigger memory exhaustion.","url":"https://insights.sbomify.com/CVE-2026-92000/"}