CVE-2026-9204 Server-Side Request Forgery (SSRF) in GitLab

Medium 5.3 Published Updated

Authenticated users can exploit insufficient URL validation during repository import to read arbitrary files and access internal network resources.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-9204?

CVE-2026-9204 is a medium-severity server-side request forgery vulnerability in Gitlab Gitlab, published on 11 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.10 before 18.10.8, 18.11 before 18.11.5, and 19.0 before 19.0.2 that under certain conditions could have allowed an authenticated user to read arbitrary files from the Gitaly server and access internal network resources during repository import, due to insufficient validation of secondary URLs.

Weakness: CWE-918

Which versions are affected by CVE-2026-9204?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.10.018.10.8, 18.11.5, 19.0.2

Products include Gitlab Gitlab.

How do I fix CVE-2026-9204?

Upgrade gitlab to a fixed version for your release line: 18.10.8, 18.11.5 or 19.0.2.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2026-9204 being exploited?

There is no known exploitation of CVE-2026-9204 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-9204, GHSA-c4m8-pv9j-v7mm, MINI-2jhr-v2hx-pv76, MINI-4x2v-f5f4-wrmv, MINI-52jm-vpxx-3658, MINI-684h-9c68-35fp and 9 more.

Is CVE-2026-9204 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free