# CVE-2026-9204: Server-Side Request Forgery (SSRF) in GitLab

> Authenticated users can exploit insufficient URL validation during repository import to read arbitrary files and access internal network resources.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** BIT-gitlab-2026-9204, GHSA-c4m8-pv9j-v7mm, MINI-2jhr-v2hx-pv76, MINI-4x2v-f5f4-wrmv, MINI-52jm-vpxx-3658, MINI-684h-9c68-35fp, MINI-h7rp-rphc-w5cx, MINI-pj3h-5fh7-rvpr, MINI-pj6v-vwhf-rx8c, MINI-r23x-95wh-w58v, MINI-vc9f-mfff-f8qx, MINI-wc6p-mgm5-g676, MINI-x83w-5gg7-c98r, MINI-xc55-7xqg-4xwj, UBUNTU-CVE-2026-9204

## What is CVE-2026-9204?

CVE-2026-9204 is a medium-severity server-side request forgery vulnerability in Gitlab Gitlab, published on 11 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.10 before 18.10.8, 18.11 before 18.11.5, and 19.0 before 19.0.2 that under certain conditions could have allowed an authenticated user to read arbitrary files from the Gitaly server and access internal network resources during repository import, due to insufficient validation of secondary URLs.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-9204?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 18.10.0 | 18.10.8, 18.11.5, 19.0.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2026-9204?

Upgrade gitlab to a fixed version for your release line: 18.10.8, 18.11.5 or 19.0.2.

## Is CVE-2026-9204 being exploited?

There is no known exploitation of CVE-2026-9204 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9204 and fix it if it is affected.

What it is: CVE-2026-9204 is a medium-severity server-side request forgery vulnerability in Gitlab Gitlab, published on 11 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-9204 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 18.10.0; fixed in 18.10.8, 18.11.5, 19.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9204/ (Markdown: https://insights.sbomify.com/CVE-2026-9204/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9204
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9204
- OSV: https://osv.dev/vulnerability/CVE-2026-9204

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9204/
Summaries are generated and may contain mistakes; the official description above is the record.
