{"answers":{"affected":"2 open source packages ship an affected version, including fastify.","exploited":"There is no known exploitation of CVE-2026-92081 in the wild and no public exploit code.","fix":"Upgrade fastify to 5.12.5 or later.","what":"CVE-2026-92081 is a medium-severity denial of service vulnerability in fastify, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-92081 and fix it if it is affected.\n\nWhat it is: CVE-2026-92081 is a medium-severity denial of service vulnerability in fastify, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-92081 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fastify (npm): affected all versions; fixed in 5.12.5\n- fastify (npm): affected all versions; fixed in 5.12.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-92081/ (Markdown: https://insights.sbomify.com/CVE-2026-92081/index.md)","id":"CVE-2026-92081","markdown":"https://insights.sbomify.com/CVE-2026-92081/index.md","name":"CVE-2026-92081","record":{"aliases":["CLSA-2026-1791626840","CLSA-2026-1791667117","CLSA-2026-1791680737","CLSA-2026-1792233310","GHSA-4mh8-r7rc-xpvc","MINI-27p9-h6qr-8354"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js web framework","requires_auth":"none","summary":"An unauthenticated attacker can crash the server by sending HTTP/2 requests to routes using response trailers, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"openjs","cpe":[],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"}],"description":"fastify is a fast and low-overhead web framework for Node.js. In versions before 5.12.5, when a route registers a response trailer via reply.trailer() and is served over HTTP/2, fastify unconditionally sets the Transfer-Encoding: chunked header, which is forbidden on HTTP/2, so Node.js throws while serializing the response headers. The exception is not caught and becomes an uncaughtException, so a single unauthenticated HTTP/2 request to any route that uses trailers crashes the server process and drops all in-flight requests, and it can be repeated on every restart. The issue is fixed in fastify 5.12.5, and users should upgrade to 5.12.5 or later. As a workaround, avoid registering response trailers with reply.trailer() on routes served over HTTP/2 until upgrading.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"fastify vulnerable to Denial of Service via unhandled exception on HTTP/2 trailer responses","id":"CVE-2026-92081","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Payara Server is vulnerable to brute-force login attacks due to the absence of a limit on failed login attempts","id":"CVE-2026-92082"},"packages":[{"ecosystem":"npm","fixed":["5.12.5"],"introduced":["0"],"last_affected":[],"package":"fastify","purl":null,"source":"GHSA-4mh8-r7rc-xpvc"},{"ecosystem":"npm","fixed":["5.12.5"],"introduced":["0"],"last_affected":[],"package":"fastify","purl":"pkg:npm/fastify","source":"GHSA-4mh8-r7rc-xpvc"}],"prev":{"headline":"Mitigation bypass in the Widget: Win32 component","id":"CVE-2026-92079"},"products":["fastify"],"published":"2026-09-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-16","vendors":["fastify"]},"summary":"An unauthenticated attacker can crash the server by sending HTTP/2 requests to routes using response trailers, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2026-92081/"}