# CVE-2026-92081: fastify vulnerable to Denial of Service via unhandled exception on HTTP/2 trailer responses

> An unauthenticated attacker can crash the server by sending HTTP/2 requests to routes using response trailers, causing a denial of service.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** CLSA-2026-1791626840, CLSA-2026-1791667117, CLSA-2026-1791680737, CLSA-2026-1792233310, GHSA-4mh8-r7rc-xpvc, MINI-27p9-h6qr-8354

## What is CVE-2026-92081?

CVE-2026-92081 is a medium-severity denial of service vulnerability in fastify, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fastify is a fast and low-overhead web framework for Node.js. In versions before 5.12.5, when a route registers a response trailer via reply.trailer() and is served over HTTP/2, fastify unconditionally sets the Transfer-Encoding: chunked header, which is forbidden on HTTP/2, so Node.js throws while serializing the response headers. The exception is not caught and becomes an uncaughtException, so a single unauthenticated HTTP/2 request to any route that uses trailers crashes the server process and drops all in-flight requests, and it can be repeated on every restart. The issue is fixed in fastify 5.12.5, and users should upgrade to 5.12.5 or later. As a workaround, avoid registering response trailers with reply.trailer() on routes served over HTTP/2 until upgrading.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-92081?

2 open source packages ship an affected version, including fastify.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastify` | npm | All versions | 5.12.5 |
| `fastify` | npm | All versions | 5.12.5 |

## How do I fix CVE-2026-92081?

Upgrade fastify to 5.12.5 or later.

## Is CVE-2026-92081 being exploited?

There is no known exploitation of CVE-2026-92081 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92081 and fix it if it is affected.

What it is: CVE-2026-92081 is a medium-severity denial of service vulnerability in fastify, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-92081 in the wild and no public exploit code.

Affected packages and fixed versions:
- fastify (npm): affected all versions; fixed in 5.12.5
- fastify (npm): affected all versions; fixed in 5.12.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92081/ (Markdown: https://insights.sbomify.com/CVE-2026-92081/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92081
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92081
- OSV: https://osv.dev/vulnerability/CVE-2026-92081

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92081/
Summaries are generated and may contain mistakes; the official description above is the record.
