CVE-2026-92087 @fastify/auth vulnerable to Authorization Bypass via order-dependent evaluation of composed auth
Attackers can bypass authorization checks in @fastify/auth by exploiting order-dependent evaluation in composed strategies, gaining unauthorized access.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-92087?
CVE-2026-92087 is a high-severity authentication bypass vulnerability in @fastify/auth, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
@fastify/auth is a Fastify plugin that composes multiple authentication and authorization strategies into a single route guard. In versions 5.0.0 through 5.1.0, when strategies are composed with the relation "or" option together with the run "all" option and one entry is a nested array acting as an AND group, the group is evaluated in an order-dependent way: an earlier failing check is silently dropped and the group's result becomes the outcome of its last check. As a result, a request that satisfies only the last member of an AND group, for example an attacker who holds a valid API key but is not an administrator, is authorized instead of rejected, and a related order-dependent bypass affects the mirror configuration where the top-level relation is "and" and a nested group uses "or". The issue is fixed in @fastify/auth 5.1.1, and users should upgrade to 5.1.1 or later. As a workaround, omit the run "all" option where it is not required, order each AND group so its stricter check is evaluated last, or replace nested AND groups with an explicit top-level "and" composition.
Which versions are affected by CVE-2026-92087?
How do I fix CVE-2026-92087?
No fix has been published for CVE-2026-92087 yet. Limit exposure of the affected software until one is available.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-92087 being exploited?
There is no known exploitation of CVE-2026-92087 in the wild and no public exploit code.
Sources
Also known as GHSA-7h52-2rwr-m76r.