# CVE-2026-92103: Mint HTTP/2 client buffers oversized frames up to 16 MiB before enforcing max_frame_size

> A malicious HTTP/2 server can cause memory exhaustion in the Mint Elixir client by sending oversized frames that are buffered before size validation.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** EEF-CVE-2026-92103, GHSA-q95c-ccq6-j5j6

## What is CVE-2026-92103?

CVE-2026-92103 is a medium-severity denial of service vulnerability in elixir-mint mint, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Allocation of Resources Without Limits or Throttling vulnerability in elixir-mint mint allows a malicious HTTP/2 server to make the client hold up to about 16 MiB per connection in frames it should reject, consuming client memory.

Mint.HTTP2.Frame.decode_next/2 in lib/mint/http2/frame.ex compares a frame with the client's max_frame_size (16,384 bytes by default) only once the whole declared payload has arrived. Until then it returns :more, and Mint.HTTP2 keeps every received byte in the connection buffer. A server can declare a frame length of up to 16,777,215 bytes and withhold the last byte, keeping roughly 1,024 times the advertised limit buffered for as long as the connection stays open. The server has to send every byte the client buffers, so there is no amplification, and the buffer stops at the 24-bit frame length limit.

This issue affects mint: from 0.1.0 before 1.10.2.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-92103?

1 open source package ship an affected version, including mint.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mint` | Hex | From 0.1.0 | 1.10.2 |

## How do I fix CVE-2026-92103?

Upgrade mint to 1.10.2 or later.

## Is CVE-2026-92103 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92103 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92103 and fix it if it is affected.

What it is: CVE-2026-92103 is a medium-severity denial of service vulnerability in elixir-mint mint, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92103 exists.

Affected packages and fixed versions:
- mint (Hex): affected from 0.1.0; fixed in 1.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92103/ (Markdown: https://insights.sbomify.com/CVE-2026-92103/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92103
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92103
- OSV: https://osv.dev/vulnerability/CVE-2026-92103

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92103/
Summaries are generated and may contain mistakes; the official description above is the record.
