# CVE-2026-92157: F´: FileDownlink SendPartial integer overflow lets legal startOffset/length values reach a reachable assertion

> Integer overflow in F Prime FileDownlink allows attackers to trigger assertion failures, causing denial of service in embedded spaceflight applications.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-hcmw-g425-8h9g

## What is CVE-2026-92157?

CVE-2026-92157 is a medium-severity vulnerability in nasa fprime, published on 14 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

F´ (F Prime) is a framework that enables development and deployment of spaceflight and other embedded software applications. Prior to 4.3.0, Svc::FileDownlink SendPartial range validation is vulnerable because unchecked startOffset plus length arithmetic bypasses the range check and stores a wrapped m_endOffset that is inconsistent with m_byteOffset. When an existing source file is larger than a valid startOffset and a SendPartial command supplies a length whose U32 sum with that offset wraps below the file size, under standard F Prime assertion handling, the first data-packet transition reaches FW_ASSERT and aborts or resets the process, causing denial of service. This issue is fixed in version 4.3.0.

Weakness: CWE-617 (Reachable Assertion), CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-92157?


## How do I fix CVE-2026-92157?

No fix has been published for CVE-2026-92157 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-92157 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92157 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92157 and fix it if it is affected.

What it is: CVE-2026-92157 is a medium-severity vulnerability in nasa fprime, published on 14 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92157 exists.

Affected product: nasa fprime. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92157/ (Markdown: https://insights.sbomify.com/CVE-2026-92157/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92157
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92157
- OSV: https://osv.dev/vulnerability/CVE-2026-92157

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92157/
Summaries are generated and may contain mistakes; the official description above is the record.
