CVE-2026-92161 FriendsOfFlarum OAuth: Unauthenticated account takeover via unverified email trust in Discord OAuth provider

Critical 9.8 Published Updated

Unauthenticated attackers can take over Flarum accounts by exploiting unverified email trust in the Discord OAuth provider when enabled.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-92161?

CVE-2026-92161 is a critical authentication bypass vulnerability in FriendsOfFlarum oauth, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

FriendsOfFlarum OAuth allows users to log in to Flarum with GitHub, Twitter, Facebook, and other providers. Prior to 1.7.4 and 2.0.0-beta.4, the Discord OAuth provider does not check the verified field returned for an OAuth email before passing the address to Flarum core as trusted through provideTrustedEmail(). When Discord sign-in is enabled, an unauthenticated attacker who knows the email address of a Flarum user can configure a Discord account with that unverified address and a verified phone number, then sign in to cause Flarum to match the trusted address, link the attacker-controlled Discord identity to the existing user, and authenticate as the victim without a password or victim interaction. Exploitation requires that the victim's email address is not already associated with a Discord account, and it can compromise administrator accounts. Other bundled providers were not confirmed to be practically exploitable by this method because their relevant authentication flows return only verified or confirmed email addresses. This issue is fixed in versions 1.7.4 and 2.0.0-beta.4.

Weakness: CWE-345

Which versions are affected by CVE-2026-92161?

4 open source packages ship an affected version, including fof/oauth.

PackageAffectedFixed in
fof/oauth PackagistAll versions1.7.4
fof/oauth PackagistAll versions1.7.4
fof/oauth PackagistFrom 2.0.0-beta.12.0.0-beta.4
fof/oauth PackagistFrom 2.0.0-beta.12.0.0-beta.4

How do I fix CVE-2026-92161?

Upgrade fof/oauth to a fixed version for your release line: 1.7.4 or 2.0.0-beta.4.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-92161 being exploited?

There is no known exploitation of CVE-2026-92161 in the wild and no public exploit code.

Sources

Also known as GHSA-g7vj-c29h-3h5m.

Is CVE-2026-92161 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free