# CVE-2026-92161: FriendsOfFlarum OAuth: Unauthenticated account takeover via unverified email trust in Discord OAuth provider

> Unauthenticated attackers can take over Flarum accounts by exploiting unverified email trust in the Discord OAuth provider when enabled.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-g7vj-c29h-3h5m

## What is CVE-2026-92161?

CVE-2026-92161 is a critical authentication bypass vulnerability in FriendsOfFlarum oauth, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FriendsOfFlarum OAuth allows users to log in to Flarum with GitHub, Twitter, Facebook, and other providers. Prior to 1.7.4 and 2.0.0-beta.4, the Discord OAuth provider does not check the verified field returned for an OAuth email before passing the address to Flarum core as trusted through provideTrustedEmail(). When Discord sign-in is enabled, an unauthenticated attacker who knows the email address of a Flarum user can configure a Discord account with that unverified address and a verified phone number, then sign in to cause Flarum to match the trusted address, link the attacker-controlled Discord identity to the existing user, and authenticate as the victim without a password or victim interaction. Exploitation requires that the victim's email address is not already associated with a Discord account, and it can compromise administrator accounts. Other bundled providers were not confirmed to be practically exploitable by this method because their relevant authentication flows return only verified or confirmed email addresses. This issue is fixed in versions 1.7.4 and 2.0.0-beta.4.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-92161?

4 open source packages ship an affected version, including fof/oauth.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fof/oauth` | Packagist | All versions | 1.7.4 |
| `fof/oauth` | Packagist | All versions | 1.7.4 |
| `fof/oauth` | Packagist | From 2.0.0-beta.1 | 2.0.0-beta.4 |
| `fof/oauth` | Packagist | From 2.0.0-beta.1 | 2.0.0-beta.4 |

## How do I fix CVE-2026-92161?

Upgrade fof/oauth to a fixed version for your release line: 1.7.4 or 2.0.0-beta.4.

## Is CVE-2026-92161 being exploited?

There is no known exploitation of CVE-2026-92161 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92161 and fix it if it is affected.

What it is: CVE-2026-92161 is a critical authentication bypass vulnerability in FriendsOfFlarum oauth, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-92161 in the wild and no public exploit code.

Affected packages and fixed versions:
- fof/oauth (Packagist): affected all versions; fixed in 1.7.4
- fof/oauth (Packagist): affected all versions; fixed in 1.7.4
- fof/oauth (Packagist): affected from 2.0.0-beta.1; fixed in 2.0.0-beta.4
- fof/oauth (Packagist): affected from 2.0.0-beta.1; fixed in 2.0.0-beta.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92161/ (Markdown: https://insights.sbomify.com/CVE-2026-92161/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92161
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92161
- OSV: https://osv.dev/vulnerability/CVE-2026-92161

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92161/
Summaries are generated and may contain mistakes; the official description above is the record.
