# CVE-2026-92162: Flatpak vulnerable to path traversal via unvalidated "arch" parameter in DeployAppstream


- **Severity:** High 7.2 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-92162, GHSA-v2gw-v9h5-9q4x, UBUNTU-CVE-2026-92162

## What is CVE-2026-92162?

CVE-2026-92162 is a high-severity vulnerability in flatpak, published on 20 Oct 2026. 

### Official description

Flatpak is a system for building, distributing, and running sandboxed desktop applications on Linux. Prior to version 1.18.1, on systems where at least one OCI remote is configured (most common on Fedora systems), a malicious local user in an active local session could use a crafted architecture name to trick the `flatpak-system-helper` process into creating a root-owned directory tree with contents determined by the OCI remote, plus a root-owned `lock` file and `icons` directory, outside the intended root directory. If this vulnerability is combined with other vulnerabilities also fixed in 1.18.1, the combination can lead to local root privilege escalation. This particular vulnerability is not believed to be exploitable if there are no OCI remotes configured (common on non-Fedora systems). Version 1.18.1 patches the issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-92162?


## How do I fix CVE-2026-92162?

Upgrade to a fixed version.

## Is CVE-2026-92162 being exploited?

There is no known exploitation of CVE-2026-92162 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-92162: Path traversal in the Flatpak system helper: an unvalidated arch parameter in DeployAppstream lets an active local user create root-owned directories anywhere. Write-up and test-mode PoC. (github_poc): https://github.com/0xSemizzz/CVE-2026-92162

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92162 and fix it if it is affected.

What it is: CVE-2026-92162 is a high-severity vulnerability in flatpak, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-92162 in the wild and no public exploit code.

Affected product: flatpak. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92162/ (Markdown: https://insights.sbomify.com/CVE-2026-92162/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92162
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92162
- OSV: https://osv.dev/vulnerability/CVE-2026-92162

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92162/
Summaries are generated and may contain mistakes; the official description above is the record.
