# CVE-2026-92263: SparkyFitness is a self-hosted, AI-powered health and fitness tracker for families.


- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 16 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** GHSA-jh96-mj9m-x796

## What is CVE-2026-92263?

CVE-2026-92263 is a high-severity vulnerability in CodeWithCJ SparkyFitness, published on 16 Oct 2026. 

### Official description

SparkyFitness is a self-hosted, AI-powered health and fitness tracker for families. Prior to 1.6.0, the api/admin/backup/restore endpoint interpolates an uploaded filename into a shell command. An authenticated global administrator uploads a restore archive with a crafted filename. The administrator can supply a restore archive with a filename containing shell metacharacters. Successful exploitation can execute arbitrary operating-system commands with the server process privileges. This issue is fixed in version 1.6.0.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-92263?


## How do I fix CVE-2026-92263?

No fix has been published for CVE-2026-92263 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-92263 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92263 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92263 and fix it if it is affected.

What it is: CVE-2026-92263 is a high-severity vulnerability in CodeWithCJ SparkyFitness, published on 16 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92263 exists.

Affected product: CodeWithCJ SparkyFitness. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92263/ (Markdown: https://insights.sbomify.com/CVE-2026-92263/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92263
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92263
- OSV: https://osv.dev/vulnerability/CVE-2026-92263

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92263/
Summaries are generated and may contain mistakes; the official description above is the record.
