# CVE-2026-92287: Pass-through of unvalidated KMS URLs to KMS clients in Apache C++ Parquet and PyArrow versions 4.0.0 to 25.0.1.


- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 20 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** AZL-109896, AZL-110001, DEBIAN-CVE-2026-92287, GHSA-3xf4-85xv-wmpw, UBUNTU-CVE-2026-92287

## What is CVE-2026-92287?

CVE-2026-92287 is a high-severity vulnerability in Apache Arrow C++, published on 20 Oct 2026. 

### Official description

Pass-through of unvalidated KMS URLs to KMS clients in Apache C++ Parquet and PyArrow versions 4.0.0 to 25.0.1.

This affects users who read Parquet files and configure Parquet decryption properties with a KmsClient implementation.

On the reader side, the KMS URL can be application-controlled (specified in the KmsConnectionConfig) or file-controlled.
If the user does not leverage application control for this parameter, a file-controlled KMS URL is forwarded to a pluggable KmsClient implementation. 
If the KMS implementation does not perform host validation and makes use of the provided KMS URL, a KMS token can be sent to a malicious host set by an attacker in the file. 

Users are recommended to upgrade to version 26.0.0, which disables this behavior by default and requires that users opt-in to it by enabling the read_kms_url flag in the DecryptionConfiguration. Users of affected versions are recommended to either specify the KMS URL in the KmsConnectionConfig when reading files, or ensure any KmsClient implementations validate received KMS URLs. Users that opt-in to file-controlled KMS URLs in version 26.0.0 and later must ensure KmsClients validate KMS URLs.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-92287?


## How do I fix CVE-2026-92287?

No fix has been published for CVE-2026-92287 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-92287 being exploited?

There is no known exploitation of CVE-2026-92287 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92287 and fix it if it is affected.

What it is: CVE-2026-92287 is a high-severity vulnerability in Apache Arrow C++, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-92287 in the wild and no public exploit code.

Affected product: Apache Arrow C++. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92287/ (Markdown: https://insights.sbomify.com/CVE-2026-92287/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92287
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92287
- OSV: https://osv.dev/vulnerability/CVE-2026-92287

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92287/
Summaries are generated and may contain mistakes; the official description above is the record.
