CVE-2026-92395 @fastify/proxy-addr vulnerable to IP spoofing via IPv4-mapped IPv6 trust subnet
Attackers can spoof IP addresses by exploiting IPv4-mapped IPv6 trust subnet parsing, bypassing IP-based access controls and rate limiting in Fastify applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-92395?
CVE-2026-92395 is a critical vulnerability in @fastify/proxy-addr, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
@fastify/proxy-addr is a Fastify plugin that determines a request's client address behind trusted reverse proxies, and it backs Fastify request.ip and request.ips. In versions 3.0.0 through 5.1.0, a trust subnet written in IPv4-mapped IPv6 notation with an IPv4-sized prefix, such as ::ffff:10.0.0.0/8 instead of the correct ::ffff:10.0.0.0/104, is accepted without error but trusts every IPv4 address on the internet rather than the block it names. Because the socket peer then becomes trusted at hop 0, any unauthenticated client can supply an arbitrary X-Forwarded-For header and control the address the application reads, which defeats IP-based access control, rate limiting, geolocation, and audit logging. The plugin inherited this defect from the upstream proxy-addr module (CVE-2026-90711). The issue is fixed in @fastify/proxy-addr 5.1.1, and users should upgrade to 5.1.1 or later. As a workaround, ensure any IPv4-mapped IPv6 trust subnet uses a prefix length of at least 97, or express the range in plain IPv4 notation.
Which versions are affected by CVE-2026-92395?
How do I fix CVE-2026-92395?
No fix has been published for CVE-2026-92395 yet. Limit exposure of the affected software until one is available.
Is CVE-2026-92395 being exploited?
There is no known exploitation of CVE-2026-92395 in the wild and no public exploit code.
Sources
Also known as GHSA-8cmm-mhw6-v7xq.