CVE-2026-92414 Apache Jackrabbit: Pre-auth hijack of cached sessions via derivable WebDAV lock tokens

Critical 9.3 Published Updated

Attackers can hijack authenticated sessions by guessing WebDAV lock tokens, allowing unauthorized access to user data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-92414?

CVE-2026-92414 is a critical authentication bypass vulnerability in Apache Jackrabbit, published on 7 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

: Session Fixation / Session Reuse across Users vulnerability in Apache Jackrabbit.

Jackrabbit WebDAV server attaches a cached authenticated session on any Lock-Token/TransactionId/SubscriptionId/If-header field token match with

no credential check.

This issue affects Apache Jackrabbit: from 2.23.0 through 2.23.5, from 2.22.0 through 2.22.4, from 2.20.0 through 2.20.17.

Users are recommended to upgrade to versions 2.23.6, 2.22.5, or 2.20.18 which fix the issue.

Weakness: CWE-384

Which versions are affected by CVE-2026-92414?

It affects 1 product.

Products include Apache Jackrabbit.

How do I fix CVE-2026-92414?

No fix has been published for CVE-2026-92414 yet. Limit exposure of the affected software until one is available.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-92414 being exploited?

There is no known exploitation of CVE-2026-92414 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-92414, GHSA-3mf8-5fj8-p748, UBUNTU-CVE-2026-92414.

Is CVE-2026-92414 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free