# CVE-2026-92414: Apache Jackrabbit: Pre-auth hijack of cached sessions via derivable WebDAV lock tokens

> Attackers can hijack authenticated sessions by guessing WebDAV lock tokens, allowing unauthorized access to user data.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-92414, GHSA-3mf8-5fj8-p748, UBUNTU-CVE-2026-92414

## What is CVE-2026-92414?

CVE-2026-92414 is a critical authentication bypass vulnerability in Apache Jackrabbit, published on 7 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

: Session Fixation / Session Reuse across Users vulnerability in Apache Jackrabbit.

Jackrabbit WebDAV server attaches a cached authenticated session on any Lock-Token/TransactionId/SubscriptionId/If-header field token match with

no credential check.

This issue affects Apache Jackrabbit: from 2.23.0 through 2.23.5, from 2.22.0 through 2.22.4, from 2.20.0 through 2.20.17.

Users are recommended to upgrade to versions 2.23.6, 2.22.5, or 2.20.18 which fix the issue.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2026-92414?

It affects 1 product.


Products: Apache Jackrabbit.

## How do I fix CVE-2026-92414?

No fix has been published for CVE-2026-92414 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-92414 being exploited?

There is no known exploitation of CVE-2026-92414 in the wild and no public exploit code.

## Other vulnerabilities in Apache Jackrabbit

- [CVE-2023-37895](https://insights.sbomify.com/CVE-2023-37895/): Apache Jackrabbit RMI access can lead to RCE (critical 9.8)
- [CVE-2025-53689](https://insights.sbomify.com/CVE-2025-53689/): Apache Jackrabbit: XXE vulnerability in jackrabbit-spi-commons (high 8.8)
- [CVE-2016-6801](https://insights.sbomify.com/CVE-2016-6801/): Apache Jackrabbit Authentication Hijacking Vulnerability (high 8.8)
- [CVE-2026-92415](https://insights.sbomify.com/CVE-2026-92415/): Apache Jackrabbit: DavEx client runs Class.forName + (String)-constructor on server-controlled error bodies (medium 6.9)
- [CVE-2025-58782](https://insights.sbomify.com/CVE-2025-58782/): Apache Jackrabbit Core, Apache Jackrabbit JCR Commons: JNDI injection risk with JndiRepositoryFactory (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92414 and fix it if it is affected.

What it is: CVE-2026-92414 is a critical authentication bypass vulnerability in Apache Jackrabbit, published on 7 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-92414 in the wild and no public exploit code.

Affected product: Apache Jackrabbit. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92414/ (Markdown: https://insights.sbomify.com/CVE-2026-92414/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92414
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92414
- OSV: https://osv.dev/vulnerability/CVE-2026-92414

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92414/
Summaries are generated and may contain mistakes; the official description above is the record.
