CVE-2026-92415 Apache Jackrabbit: DavEx client runs Class.forName + (String)-constructor on server-controlled error bodies

Medium 6.9 Published Updated

A malicious WebDAV server can trigger unsafe reflection in the Jackrabbit client, allowing arbitrary class instantiation and potential file manipulation.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-92415?

CVE-2026-92415 is a medium-severity unsafe deserialization vulnerability in Apache Jackrabbit, published on 7 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

— Use of Externally-Controlled Input to Select Classes or Code vulnerability in Apache Jackrabbit's WebDAV/Davex client.

A malicious WebDAV/DavEx server, or an attacker able to intercept the connection, can cause the client to instantiate arbitrary classes from its classpath, which can lead to arbitrary file creation or truncation.

Only applications that use jackrabbit-spi2dav (directly or through jackrabbit-jcr2dav) to connect to a remote repository are affected. Jackrabbit servers are not affected.

Category: unsafe reflection on wire data (HIGH).

This issue affects Apache Jackrabbit: from 2.23.0 through 2.23.5, from 2.22.0 through 2.22.4, from 2.20.0 through 2.20.17.

Users are recommended to upgrade to versions 2.23.6, 2.22.5, or 2.20.18 which fix the issue.

Weakness: CWE-470

Which versions are affected by CVE-2026-92415?

It affects 1 product.

Products include Apache Jackrabbit.

How do I fix CVE-2026-92415?

No fix has been published for CVE-2026-92415 yet. Limit exposure of the affected software until one is available.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2026-92415 being exploited?

There is no known exploitation of CVE-2026-92415 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-92415, GHSA-f7m4-mw9m-xwg5, UBUNTU-CVE-2026-92415.

Is CVE-2026-92415 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free