# CVE-2026-92415: Apache Jackrabbit: DavEx client runs Class.forName + (String)-constructor on server-controlled error bodies

> A malicious WebDAV server can trigger unsafe reflection in the Jackrabbit client, allowing arbitrary class instantiation and potential file manipulation.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/S:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-92415, GHSA-f7m4-mw9m-xwg5, UBUNTU-CVE-2026-92415

## What is CVE-2026-92415?

CVE-2026-92415 is a medium-severity unsafe deserialization vulnerability in Apache Jackrabbit, published on 7 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

— Use of Externally-Controlled Input to Select Classes or Code vulnerability in Apache Jackrabbit's WebDAV/Davex client.

A malicious WebDAV/DavEx server, or an attacker able to intercept the connection, can cause the client to instantiate arbitrary classes from its classpath, which can lead to arbitrary file creation or truncation.

Only applications that use jackrabbit-spi2dav (directly or through jackrabbit-jcr2dav) to connect to a remote repository are affected. Jackrabbit servers are not affected.

Category: unsafe reflection on wire data (HIGH).

This issue affects Apache Jackrabbit: from 2.23.0 through 2.23.5, from 2.22.0 through 2.22.4, from 2.20.0 through 2.20.17.

Users are recommended to upgrade to versions 2.23.6, 2.22.5, or 2.20.18 which fix the issue.

Weakness: CWE-470 (Use of Externally-Controlled Input to Select Classes or Code)

## Which versions are affected by CVE-2026-92415?

It affects 1 product.


Products: Apache Jackrabbit.

## How do I fix CVE-2026-92415?

No fix has been published for CVE-2026-92415 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-92415 being exploited?

There is no known exploitation of CVE-2026-92415 in the wild and no public exploit code.

## Other vulnerabilities in Apache Jackrabbit

- [CVE-2023-37895](https://insights.sbomify.com/CVE-2023-37895/): Apache Jackrabbit RMI access can lead to RCE (critical 9.8)
- [CVE-2026-92414](https://insights.sbomify.com/CVE-2026-92414/): Apache Jackrabbit: Pre-auth hijack of cached sessions via derivable WebDAV lock tokens (critical 9.3)
- [CVE-2025-53689](https://insights.sbomify.com/CVE-2025-53689/): Apache Jackrabbit: XXE vulnerability in jackrabbit-spi-commons (high 8.8)
- [CVE-2016-6801](https://insights.sbomify.com/CVE-2016-6801/): Apache Jackrabbit Authentication Hijacking Vulnerability (high 8.8)
- [CVE-2025-58782](https://insights.sbomify.com/CVE-2025-58782/): Apache Jackrabbit Core, Apache Jackrabbit JCR Commons: JNDI injection risk with JndiRepositoryFactory (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92415 and fix it if it is affected.

What it is: CVE-2026-92415 is a medium-severity unsafe deserialization vulnerability in Apache Jackrabbit, published on 7 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-92415 in the wild and no public exploit code.

Affected product: Apache Jackrabbit. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92415/ (Markdown: https://insights.sbomify.com/CVE-2026-92415/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92415
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92415
- OSV: https://osv.dev/vulnerability/CVE-2026-92415

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92415/
Summaries are generated and may contain mistakes; the official description above is the record.
