CVE-2026-92528 Incorrect Authorization in GitLab

Medium 4.2 Published Updated

Authenticated users can improperly approve merge requests they contributed to, bypassing intended authorization controls in GitLab EE.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-92528?

CVE-2026-92528 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 13 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 16.11 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user to approve a merge request despite having contributed commits to it, due to improper identity resolution.

Weakness: CWE-863

Which versions are affected by CVE-2026-92528?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.11.019.2.8, 19.3.5, 19.4.2

Products include Gitlab Gitlab.

How do I fix CVE-2026-92528?

Upgrade gitlab to a fixed version for your release line: 19.2.8, 19.3.5 or 19.4.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-92528 being exploited?

There is no known exploitation of CVE-2026-92528 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-92528, GHSA-3wqg-xrf4-q3m8, MINI-7v9h-wh8r-qvrh, MINI-7vwc-rwhq-3whr, MINI-w3jg-j759-vhv7, UBUNTU-CVE-2026-92528.

Is CVE-2026-92528 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free