CVE-2026-92529 Incorrect Authorization in GitLab

Medium 4.3 Published Updated

Authenticated developers can bypass admin-configured AI tool governance controls in uncontrolled namespaces due to improper authorization checks.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-92529?

CVE-2026-92529 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 23 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 19.1 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 that under certain conditions could have allowed an authenticated user with developer-role permissions to bypass admin-configured AI tool governance controls for workflows in namespaces they do not control due to improper authorization checks.

Weakness: CWE-863

Which versions are affected by CVE-2026-92529?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 19.1.019.2.7, 19.3.3, 19.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2026-92529?

Upgrade gitlab to a fixed version for your release line: 19.2.7, 19.3.3 or 19.4.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-92529 being exploited?

There is no known exploitation of CVE-2026-92529 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-92529, GHSA-cfwp-mfvj-r9jm, MINI-8q3f-438v-649r, MINI-c2vh-46cg-6592, MINI-xhwx-gjx7-hfhw.

Is CVE-2026-92529 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free