{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-92550 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-92550 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-92550 is a high-severity denial of service vulnerability in Apache Qpid Broker-J, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-92550 and fix it if it is affected.\n\nWhat it is: CVE-2026-92550 is a high-severity denial of service vulnerability in Apache Qpid Broker-J, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-92550 in the wild and no public exploit code.\n\nAffected product: Apache Qpid Broker-J. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-92550/ (Markdown: https://insights.sbomify.com/CVE-2026-92550/index.md)","id":"CVE-2026-92550","markdown":"https://insights.sbomify.com/CVE-2026-92550/index.md","name":"CVE-2026-92550","record":{"aliases":["GHSA-jwgh-mqvv-gpfh"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"AMQP message broker","requires_auth":"none","summary":"A pre-authentication attacker can cause excessive memory allocation in Apache Qpid Broker-J, leading to denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"qpid_broker-j","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-789","name":"Memory Allocation with Excessive Size Value"}],"description":"A pre-authentication attacker could leverage type size/count handling to cause excessive allocation leading to potential denial of service.\n\nThis issue affects Apache Qpid Broker-J: through 10.1.0.\n\nUsers are recommended to upgrade to version 10.1.1, which fixes the issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Denial of service in Apache Qpid Broker-J","id":"CVE-2026-92550","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"Cross-site scripting in Paid Membership Plugin, Ecommerce, User Registration Form, Login Form, User Profile \u0026 Restrict Content – ProfilePress","id":"CVE-2026-92551"},"packages":[],"prev":{"headline":"WP Popular Posts \u003c= 7.4.2 - Unauthenticated Information Disclosure in 'post_type' and 'context' Parameters","id":"CVE-2026-92548"},"products":["Apache Qpid Broker-J"],"published":"2026-09-25","related":[{"cvss_score":9.8,"headline":"Apache Qpid Broker-J: Missing HTTP-session renewal after successful authentication","id":"CVE-2026-92609","kev_date_added":null,"published":"2026-09-25"},{"cvss_score":9.8,"headline":"Apache Qpid Broker vulnerable to authentication port spoofing","id":"CVE-2017-15702","kev_date_added":null,"published":"2017-12-01"},{"cvss_score":9.1,"headline":"AMQP 0-8, 0-9, 0-91, and 0-10 connection handling in Apache Qpid Java before 6.0.3 might allow remote attackers to bypass authentication","id":"CVE-2016-4432","kev_date_added":null,"published":"2016-06-01"},{"cvss_score":7.5,"headline":"Denial of service in Apache Qpid Broker-J","id":"CVE-2026-92560","kev_date_added":null,"published":"2026-09-25"},{"cvss_score":7.5,"headline":"Denial of service in Apache Qpid Broker-J","id":"CVE-2026-92564","kev_date_added":null,"published":"2026-09-25"},{"cvss_score":7.5,"headline":"Apache Qpid Broker-J: Incomplete property conversion handling from AMQP 1.0 to AMQP 0-10","id":"CVE-2026-92608","kev_date_added":null,"published":"2026-09-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-25","vendors":["Apache Software Foundation"]},"summary":"A pre-authentication attacker can cause excessive memory allocation in Apache Qpid Broker-J, leading to denial of service.","url":"https://insights.sbomify.com/CVE-2026-92550/"}