CVE-2026-92564 Denial of service in Apache Qpid Broker-J

High 7.5 Published Updated

A pre-authentication attacker can cause a stack overflow and denial of service in Apache Qpid Broker-J by exploiting unbounded type nesting in AMQP field-table processing.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-92564?

CVE-2026-92564 is a high-severity denial of service vulnerability in Apache Qpid Broker-J, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service.

This issue affects Apache Qpid Broker-J: through 10.1.0.

Users are recommended to upgrade to version 10.1.1, which fixes the issue.

Weakness: CWE-674

Which versions are affected by CVE-2026-92564?

It affects 1 product.

Products include Apache Qpid Broker-J.

How do I fix CVE-2026-92564?

No fix has been published for CVE-2026-92564 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-92564 being exploited?

There is no known exploitation of CVE-2026-92564 in the wild and no public exploit code.

Sources

Also known as GHSA-fx75-4pp2-mgc8.

Is CVE-2026-92564 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free