# CVE-2026-92591: Craft CMS 5.0.0 before 5.10.13 Environment Secret Exposure via Installer

> An unauthenticated attacker can expose sensitive environment variables and secrets if a database outage occurs, allowing access to credentials and keys.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-fq6c-26cc-63cr, GHSA-hfjh-gw6x-7pv5

## What is CVE-2026-92591?

CVE-2026-92591 is a high-severity vulnerability in craftcms cms, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Craft CMS 5.0.0 through 5.10.12 treats a database connection failure as meaning that Craft is not installed, which makes anonymous installer actions — including install/validate-site — reachable on an installed production site whenever PHP remains available but the configured MySQL endpoint does not. The action accepts a site name, serializes it through Site::getName(), and expands ${NAME} expressions using App::env(). An unauthenticated attacker who obtained a guest session cookie and matching CSRF token before the outage and whose session remains valid during it can submit a predictable variable name (for example Craft's conventional CRAFT_SECURITY_KEY) and receive its value, disclosing Craft secrets, process environment variables, $_SERVER entries, or PHP constants such as the security key, database credentials, or API keys. The issue requires an independently occurring database outage; the vulnerability itself provides no way to induce it. Fixed in 5.10.13.

Weakness: CWE-636 (Not Failing Securely)

## Which versions are affected by CVE-2026-92591?


## How do I fix CVE-2026-92591?

No fix has been published for CVE-2026-92591 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-92591 being exploited?

There is no known exploitation of CVE-2026-92591 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92591 and fix it if it is affected.

What it is: CVE-2026-92591 is a high-severity vulnerability in craftcms cms, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-92591 in the wild and no public exploit code.

Affected product: craftcms cms. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92591/ (Markdown: https://insights.sbomify.com/CVE-2026-92591/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92591
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92591
- OSV: https://osv.dev/vulnerability/CVE-2026-92591

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92591/
Summaries are generated and may contain mistakes; the official description above is the record.
