# CVE-2026-92595: Nodemailer before 9.1.1 Security Sandbox Bypass via resolveContent

> Attackers can bypass sandbox restrictions in Nodemailer to read local files or perform SSRF via the resolveContent API.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 19 Sep 2026
- **Also known as:** CLEANSTART-2026-MI57025, CLEANSTART-2026-VQ15547, CLEANSTART-2026-YT99310, CLSA-2026-1788978110, CLSA-2026-1790109128, DEBIAN-CVE-2026-92595, ECHO-1dee-8def-9142, GHSA-5635-p6jj-6g9p, GHSA-8m3c-c648-2xjj, MINI-28vp-2hp4-rprm, MINI-8pmp-2937-484q, MINI-8vh5-cqv3-wc45, MINI-92wp-7h4c-29j6, MINI-chrg-7f94-44qw, MINI-chvp-cf7p-h7h8, MINI-ggrg-246m-v5cp, MINI-h649-f4g3-2vr3, MINI-h6cp-rcv3-j44x, MINI-hhpp-v75v-pmpp, MINI-m3hx-3j69-47v8, MINI-mqw5-pwrr-jf56, MINI-p225-hcvf-rvfx, MINI-pp9c-8p9g-f9w4, MINI-q8rp-pfw3-hww4, MINI-w496-p2cc-qg6r, UBUNTU-CVE-2026-92595

## What is CVE-2026-92595?

CVE-2026-92595 is a medium-severity server-side request forgery vulnerability in nodemailer, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nodemailer (npm package `nodemailer`) versions 9.1.0 and earlier do not honor the `disableFileAccess` and `disableUrlAccess` sandbox options when message content is resolved through the public plugin API `MailMessage.resolveContent()` using the documented legacy three-argument signature `resolveContent(data, key, callback)`. Because `shared.resolveContent()` normalizes the missing `options` argument to an empty object, the message-level flags copied into `mail.data` by the MailMessage constructor are discarded, and `resolveContentValue()` skips both access-control checks, reaching `nmfetch(url)` or `fs.createReadStream(path)`. As a result, plugin or application code that resolves untrusted message content (html, text, attachment `path` or `href`) via this API can be induced to read arbitrary local files or issue outbound HTTP(S) requests (server-side request forgery), bypassing the sandbox the application enabled. The internal paths used by `transporter.sendMail()` (`resolveAll()`, `_convertDataImages()`, and the MIME streaming path) are not affected. Fixed in version 9.1.1.

Weakness: CWE-73 (External Control of File Name or Path)

## Which versions are affected by CVE-2026-92595?

2 open source packages ship an affected version, including nodemailer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodemailer` | npm | All versions | 9.1.1 |
| `nodemailer` | npm | All versions | 9.1.1 |

## How do I fix CVE-2026-92595?

Upgrade nodemailer to 9.1.1 or later.

## Is CVE-2026-92595 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92595 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92595 and fix it if it is affected.

What it is: CVE-2026-92595 is a medium-severity server-side request forgery vulnerability in nodemailer, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92595 exists.

Affected packages and fixed versions:
- nodemailer (npm): affected all versions; fixed in 9.1.1
- nodemailer (npm): affected all versions; fixed in 9.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92595/ (Markdown: https://insights.sbomify.com/CVE-2026-92595/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92595
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92595
- OSV: https://osv.dev/vulnerability/CVE-2026-92595

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92595/
Summaries are generated and may contain mistakes; the official description above is the record.
