{"answers":{"affected":"2 open source packages ship an affected version, including nodemailer.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92598 exists.","fix":"Upgrade nodemailer to 9.1.0 or later.","what":"CVE-2026-92598 is a high-severity vulnerability in nodemailer, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-92598 and fix it if it is affected.\n\nWhat it is: CVE-2026-92598 is a high-severity vulnerability in nodemailer, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92598 exists.\n\nAffected packages and fixed versions:\n- nodemailer (npm): affected all versions; fixed in 9.1.0\n- nodemailer (npm): affected all versions; fixed in 9.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-92598/ (Markdown: https://insights.sbomify.com/CVE-2026-92598/index.md)","id":"CVE-2026-92598","markdown":"https://insights.sbomify.com/CVE-2026-92598/index.md","name":"CVE-2026-92598","record":{"aliases":["CLEANSTART-2026-CB36815","CLEANSTART-2026-EW00525","CLEANSTART-2026-NC98199","DEBIAN-CVE-2026-92598","ECHO-9f3a-0677-e28a","GHSA-r7q5-h7cx-p54x","GHSA-wmmp-3585-3rmp","MINI-3w53-8q5q-q5cm","MINI-5pc6-m32f-r4j6","MINI-7x7m-4938-57g3","MINI-8hx8-558x-498r","MINI-9h56-ppvq-wqjj","MINI-cw94-cjm2-q9w3","MINI-fj5q-fw8h-gj7q","MINI-gjvr-w5pc-m9j6","MINI-j25c-mwqx-pj78","MINI-jchw-jx7g-p2p5","MINI-pc46-p288-7f43","MINI-qc52-wwqg-2898","MINI-v6qp-vxvg-qgcx","MINI-www5-p5m5-fc9f","MINI-xr79-6fw9-qf98","MINI-xxh9-cp27-pcqg","UBUNTU-CVE-2026-92598"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js email library","requires_auth":"none","summary":"Attackers can bypass domain allow-lists in Nodemailer by exploiting IDN normalization flaws to send emails to unauthorized domains.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-436","name":"Interpretation Conflict"}],"description":"Nodemailer before 9.1.0 fails to apply UTS-46 normalization when encoding international domain names, causing the domain resolver to compute a different Punycode A-label than standards-compliant parsers. Attackers can craft recipient addresses with invisible characters or compatibility mappings that pass domain allow-list checks but are delivered to attacker-controlled domains via SMTP.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Nodemailer before 9.1.0 IDN/Punycode Domain Allow-list Bypass","id":"CVE-2026-92598","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"Joi before 17.13.7 and 18.2.6 ReDoS via isoDate","id":"CVE-2026-92599"},"packages":[{"ecosystem":"npm","fixed":["9.1.0"],"introduced":["0"],"last_affected":[],"package":"nodemailer","purl":null,"source":"GHSA-wmmp-3585-3rmp"},{"ecosystem":"npm","fixed":["9.1.0"],"introduced":["0"],"last_affected":[],"package":"nodemailer","purl":"pkg:npm/nodemailer","source":"GHSA-wmmp-3585-3rmp"}],"prev":{"headline":"Nodemailer before 9.1.0 Email Domain Validation Bypass via RFC 5322 Comment","id":"CVE-2026-92597"},"products":["nodemailer"],"published":"2026-09-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-17","vendors":["nodemailer"]},"summary":"Attackers can bypass domain allow-lists in Nodemailer by exploiting IDN normalization flaws to send emails to unauthorized domains.","url":"https://insights.sbomify.com/CVE-2026-92598/"}