# CVE-2026-92598: Nodemailer before 9.1.0 IDN/Punycode Domain Allow-list Bypass

> Attackers can bypass domain allow-lists in Nodemailer by exploiting IDN normalization flaws to send emails to unauthorized domains.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** CLEANSTART-2026-CB36815, CLEANSTART-2026-EW00525, CLEANSTART-2026-NC98199, DEBIAN-CVE-2026-92598, ECHO-9f3a-0677-e28a, GHSA-r7q5-h7cx-p54x, GHSA-wmmp-3585-3rmp, MINI-3w53-8q5q-q5cm, MINI-5pc6-m32f-r4j6, MINI-7x7m-4938-57g3, MINI-8hx8-558x-498r, MINI-9h56-ppvq-wqjj, MINI-cw94-cjm2-q9w3, MINI-fj5q-fw8h-gj7q, MINI-gjvr-w5pc-m9j6, MINI-j25c-mwqx-pj78, MINI-jchw-jx7g-p2p5, MINI-pc46-p288-7f43, MINI-qc52-wwqg-2898, MINI-v6qp-vxvg-qgcx, MINI-www5-p5m5-fc9f, MINI-xr79-6fw9-qf98, MINI-xxh9-cp27-pcqg, UBUNTU-CVE-2026-92598

## What is CVE-2026-92598?

CVE-2026-92598 is a high-severity vulnerability in nodemailer, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nodemailer before 9.1.0 fails to apply UTS-46 normalization when encoding international domain names, causing the domain resolver to compute a different Punycode A-label than standards-compliant parsers. Attackers can craft recipient addresses with invisible characters or compatibility mappings that pass domain allow-list checks but are delivered to attacker-controlled domains via SMTP.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2026-92598?

2 open source packages ship an affected version, including nodemailer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodemailer` | npm | All versions | 9.1.0 |
| `nodemailer` | npm | All versions | 9.1.0 |

## How do I fix CVE-2026-92598?

Upgrade nodemailer to 9.1.0 or later.

## Is CVE-2026-92598 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92598 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92598 and fix it if it is affected.

What it is: CVE-2026-92598 is a high-severity vulnerability in nodemailer, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92598 exists.

Affected packages and fixed versions:
- nodemailer (npm): affected all versions; fixed in 9.1.0
- nodemailer (npm): affected all versions; fixed in 9.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92598/ (Markdown: https://insights.sbomify.com/CVE-2026-92598/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92598
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92598
- OSV: https://osv.dev/vulnerability/CVE-2026-92598

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92598/
Summaries are generated and may contain mistakes; the official description above is the record.
