CVE-2026-92599 Joi before 17.13.7 and 18.2.6 ReDoS via isoDate

High 8.7 Published Updated

A remote attacker can cause a denial of service in applications using Joi by submitting a specially crafted ISO date string that triggers excessive regex processing.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-92599?

CVE-2026-92599 is a high-severity denial of service vulnerability in hapijs joi, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

joi (npm package `joi`, hapi.js) versions >=17.2.0 <17.13.7 and >=18.0.0 <18.2.6 are vulnerable to regular expression denial of service in the `Joi.string().isoDate()` validation rule. One of the regular expressions the rule applies to the input is unanchored, so a valid ISO date followed by a long run of fractional-second digits causes the regex engine to restart its search from every position in the string, yielding time proportional to the square of the input length (about 1.4 s for 64 KB of digits and about 22 s for 256 KB). A remote attacker who can supply a string to an isoDate validation can stall the application with a single request. Fixed in 17.13.7 and 18.2.6; as a workaround, cap the length of the string before it reaches joi.

Weakness: CWE-1333

Which versions are affected by CVE-2026-92599?

4 open source packages ship an affected version, including joi.

PackageAffectedFixed in
joi npmFrom 17.2.017.13.7
joi npmFrom 17.2.017.13.7
joi npmFrom 18.0.018.2.6
joi npmFrom 18.0.018.2.6

How do I fix CVE-2026-92599?

Upgrade joi to a fixed version for your release line: 17.13.7 or 18.2.6.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-92599 being exploited?

There is no known exploitation of CVE-2026-92599 in the wild and no public exploit code.

Sources

Also known as CLSA-2026-1790719586, ECHO-6a04-a4c8-a01f, GHSA-6h2x-m376-mqjq, MINI-3ccg-8x88-gjrr, MINI-442p-5382-wq2q, MINI-48j7-vm2r-cvj5 and 17 more.

Is CVE-2026-92599 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free