CVE-2026-92608 Apache Qpid Broker-J: Incomplete property conversion handling from AMQP 1.0 to AMQP 0-10

High 7.5 Published Updated

Authenticated attackers can disrupt message delivery to AMQP 0-10 consumers by sending messages with improperly handled property encodings.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-92608?

CVE-2026-92608 is a high-severity denial of service vulnerability in Apache Qpid Broker-J, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper handling of property-encoding exceptions in AMQP 1.0-to-AMQP 0-10 message conversion allows authenticated message producers to disrupt delivery to AMQP 0-10 consumers via message properties that the target encoder does not handle correctly.

This issue affects Apache Qpid Broker-J: through 10.1.0.

Users are recommended to upgrade to version 10.1.1, which fixes the issue.

Weakness: CWE-248

Which versions are affected by CVE-2026-92608?

It affects 1 product.

Products include Apache Qpid Broker-J.

How do I fix CVE-2026-92608?

No fix has been published for CVE-2026-92608 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-92608 being exploited?

There is no known exploitation of CVE-2026-92608 in the wild and no public exploit code.

Sources

Also known as GHSA-vvvh-6236-74pm.

Is CVE-2026-92608 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free