# CVE-2026-92609: Apache Qpid Broker-J: Missing HTTP-session renewal after successful authentication

> Remote attackers can hijack authenticated management sessions via session fixation, requiring an upgrade to Apache Qpid Broker-J.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Sep 2026
- **Updated:** 25 Sep 2026
- **Also known as:** GHSA-ph2j-h7vv-mhxg

## What is CVE-2026-92609?

CVE-2026-92609 is a critical authentication bypass vulnerability in Apache Qpid Broker-J, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Session fixation in HTTP management authentication allows remote attackers to gain unauthorized access to an authenticated management session via reuse of a session identifier retained across successful authentication.

This issue affects Apache Qpid Broker-J: through 10.1.0.

Users are recommended to upgrade to version 10.1.1, which fixes the issue.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2026-92609?

It affects 1 product.


Products: Apache Qpid Broker-J.

## How do I fix CVE-2026-92609?

No fix has been published for CVE-2026-92609 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-92609 being exploited?

There is no known exploitation of CVE-2026-92609 in the wild and no public exploit code.

## Other vulnerabilities in Apache Qpid Broker-J

- [CVE-2017-15702](https://insights.sbomify.com/CVE-2017-15702/): Apache Qpid Broker vulnerable to authentication port spoofing (critical 9.8)
- [CVE-2016-4432](https://insights.sbomify.com/CVE-2016-4432/): AMQP 0-8, 0-9, 0-91, and 0-10 connection handling in Apache Qpid Java before 6.0.3 might allow remote attackers to bypass authentication (critical 9.1)
- [CVE-2026-92550](https://insights.sbomify.com/CVE-2026-92550/): Denial of service in Apache Qpid Broker-J (high 7.5)
- [CVE-2026-92560](https://insights.sbomify.com/CVE-2026-92560/): Denial of service in Apache Qpid Broker-J (high 7.5)
- [CVE-2026-92564](https://insights.sbomify.com/CVE-2026-92564/): Denial of service in Apache Qpid Broker-J (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92609 and fix it if it is affected.

What it is: CVE-2026-92609 is a critical authentication bypass vulnerability in Apache Qpid Broker-J, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-92609 in the wild and no public exploit code.

Affected product: Apache Qpid Broker-J. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92609/ (Markdown: https://insights.sbomify.com/CVE-2026-92609/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92609
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92609
- OSV: https://osv.dev/vulnerability/CVE-2026-92609

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92609/
Summaries are generated and may contain mistakes; the official description above is the record.
