# CVE-2026-92612: Memory corruption in Eclipse iceoryx™

> Attackers can trigger undefined behavior and potential crashes or code execution by creating invalid string slices via unsafe mutable byte access in the iceoryx2 library.

- **Severity:** Low 1.0 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:H/UI:A/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** GHSA-8mq4-3mwq-qvg6, GHSA-gm83-3hcx-j6jj, RUSTSEC-2026-0294

## What is CVE-2026-92612?

CVE-2026-92612 is a low-severity memory corruption vulnerability in Eclipse iceoryx™, published on 21 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In Eclipse iceoryx2 versions greater than v0.8.0, the StaticString exposes its contents as mutable bytes through safe APIs, while String::as_str() converts those bytes into a Rust string slice without validating UTF-8. An application can therefore create an invalid &str and trigger undefined behavior using entirely safe Rust.

Weakness: CWE-749 (Exposed Dangerous Method or Function)

## Which versions are affected by CVE-2026-92612?

1 open source package ship an affected version, including iceoryx2-bb-container.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `iceoryx2-bb-container` | crates.io | From 0.0.0-0 | 0.10.0 |

## How do I fix CVE-2026-92612?

Upgrade iceoryx2-bb-container to 0.10.0 or later.

## Is CVE-2026-92612 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92612 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92612 and fix it if it is affected.

What it is: CVE-2026-92612 is a low-severity memory corruption vulnerability in Eclipse iceoryx™, published on 21 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92612 exists.

Affected packages and fixed versions:
- iceoryx2-bb-container (crates.io): affected from 0.0.0-0; fixed in 0.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92612/ (Markdown: https://insights.sbomify.com/CVE-2026-92612/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92612
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92612
- OSV: https://osv.dev/vulnerability/CVE-2026-92612

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92612/
Summaries are generated and may contain mistakes; the official description above is the record.
