CVE-2026-9268 Incorrect Authorization in GitLab

Low 2.7 Published Updated

Authenticated users with limited permissions could modify project CI/CD deployment rollback settings due to insufficient access control checks.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-9268?

CVE-2026-9268 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 13 Oct 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 13.6 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user with limited permissions to modify project CI/CD deployment rollback settings without proper authorization, due to insufficient access control checks.

Weakness: CWE-863

Which versions are affected by CVE-2026-9268?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.6.019.2.8, 19.3.5, 19.4.2

Products include Gitlab Gitlab.

How do I fix CVE-2026-9268?

Upgrade gitlab to a fixed version for your release line: 19.2.8, 19.3.5 or 19.4.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-9268 being exploited?

There is no known exploitation of CVE-2026-9268 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-9268, GHSA-f65j-g87j-ff2x, MINI-gmwx-2whp-vhpm, MINI-qgm9-5rj5-fvx7, MINI-r5g6-f54w-f5mj, UBUNTU-CVE-2026-9268.

Is CVE-2026-9268 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free