# CVE-2026-92681: @neo4j/graphql: schema-level and type-level @authentication not enforced on top-level @cypher fields

> Unauthenticated attackers can execute top-level Cypher queries if schema-level authentication directives are used, bypassing intended access controls.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** GHSA-8xj4-8gg9-fx9h

## What is CVE-2026-92681?

CVE-2026-92681 is a critical missing authorization vulnerability in @neo4j/graphql, published on 12 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In @neo4j/graphql versions up to and including 7.6.3, @authentication directives applied at the schema level or on the Query or Mutation types are silently ignored for top-level fields annotated with @cypher. Only @authentication directives placed directly on the individual fields are enforced. An application that exposes a top-level @cypher field and relies on schema-level or type-level @authentication to protect it allows unauthenticated callers to invoke the field and run the configured Cypher statement with the privileges of the GraphQL service account, which may permit reading and modifying data. Fixed in 7.6.4.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-92681?


## How do I fix CVE-2026-92681?

No fix has been published for CVE-2026-92681 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-92681 being exploited?

There is no known exploitation of CVE-2026-92681 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92681 and fix it if it is affected.

What it is: CVE-2026-92681 is a critical missing authorization vulnerability in @neo4j/graphql, published on 12 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-92681 in the wild and no public exploit code.

Affected product: @neo4j/graphql. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92681/ (Markdown: https://insights.sbomify.com/CVE-2026-92681/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92681
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92681
- OSV: https://osv.dev/vulnerability/CVE-2026-92681

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92681/
Summaries are generated and may contain mistakes; the official description above is the record.
