CVE-2026-92692 Sulu: JCR-SQL2 injection via `categories` query parameter (unauthenticated)
Unauthenticated attackers can inject JCR-SQL2 queries via the categories parameter to read unpublished content or cause denial of service in Sulu CMS.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-92692?
CVE-2026-92692 is a medium-severity SQL injection vulnerability in sulu, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Sulu is an open-source PHP content management system based on the Symfony framework. Prior to 2.6.25 and 3.0.8, the affected Sulu 2.6 and 3.0 release lines have a Smart Content QueryBuilder in src/Sulu/Component/Content/SmartContent/QueryBuilder.php that concatenates category identifiers from the public categories query parameter into a JCR-SQL2 WHERE clause without numeric validation. On a public page containing a category-filtered Smart Content block, an unauthenticated attacker can alter query conditions to infer or enumerate content-repository nodes, including unpublished content, or submit malformed and expensive query fragments that degrade availability; this path does not modify repository data. This issue is fixed in versions 2.6.25 and 3.0.8.
Weakness: CWE-89
Which versions are affected by CVE-2026-92692?
4 open source packages ship an affected version, including sulu/sulu.
| Package | Affected | Fixed in |
|---|---|---|
sulu/sulu Packagist | All versions | 2.6.25 |
sulu/sulu Packagist | All versions | 2.6.25 |
sulu/sulu Packagist | From 3.0.0 | 3.0.8 |
sulu/sulu Packagist | From 3.0.0 | 3.0.8 |
How do I fix CVE-2026-92692?
Upgrade sulu/sulu to a fixed version for your release line: 2.6.25 or 3.0.8.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2026-92692 being exploited?
There is no known exploitation of CVE-2026-92692 in the wild and no public exploit code.
Sources
Also known as GHSA-jg26-q8hg-3pq4, UBUNTU-CVE-2026-92692.