# CVE-2026-92692: Sulu: JCR-SQL2 injection via `categories` query parameter (unauthenticated)

> Unauthenticated attackers can inject JCR-SQL2 queries via the categories parameter to read unpublished content or cause denial of service in Sulu CMS.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** GHSA-jg26-q8hg-3pq4, UBUNTU-CVE-2026-92692

## What is CVE-2026-92692?

CVE-2026-92692 is a medium-severity SQL injection vulnerability in sulu, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Sulu is an open-source PHP content management system based on the Symfony framework. Prior to 2.6.25 and 3.0.8, the affected Sulu 2.6 and 3.0 release lines have a Smart Content QueryBuilder in src/Sulu/Component/Content/SmartContent/QueryBuilder.php that concatenates category identifiers from the public categories query parameter into a JCR-SQL2 WHERE clause without numeric validation. On a public page containing a category-filtered Smart Content block, an unauthenticated attacker can alter query conditions to infer or enumerate content-repository nodes, including unpublished content, or submit malformed and expensive query fragments that degrade availability; this path does not modify repository data. This issue is fixed in versions 2.6.25 and 3.0.8.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-92692?

4 open source packages ship an affected version, including sulu/sulu.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sulu/sulu` | Packagist | All versions | 2.6.25 |
| `sulu/sulu` | Packagist | All versions | 2.6.25 |
| `sulu/sulu` | Packagist | From 3.0.0 | 3.0.8 |
| `sulu/sulu` | Packagist | From 3.0.0 | 3.0.8 |

## How do I fix CVE-2026-92692?

Upgrade sulu/sulu to a fixed version for your release line: 2.6.25 or 3.0.8.

## Is CVE-2026-92692 being exploited?

There is no known exploitation of CVE-2026-92692 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92692 and fix it if it is affected.

What it is: CVE-2026-92692 is a medium-severity SQL injection vulnerability in sulu, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-92692 in the wild and no public exploit code.

Affected packages and fixed versions:
- sulu/sulu (Packagist): affected all versions; fixed in 2.6.25
- sulu/sulu (Packagist): affected all versions; fixed in 2.6.25
- sulu/sulu (Packagist): affected from 3.0.0; fixed in 3.0.8
- sulu/sulu (Packagist): affected from 3.0.0; fixed in 3.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92692/ (Markdown: https://insights.sbomify.com/CVE-2026-92692/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92692
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92692
- OSV: https://osv.dev/vulnerability/CVE-2026-92692

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92692/
Summaries are generated and may contain mistakes; the official description above is the record.
