{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-92706 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-92706 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-92706 is a low-severity server-side request forgery vulnerability in darkreader, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-92706 and fix it if it is affected.\n\nWhat it is: CVE-2026-92706 is a low-severity server-side request forgery vulnerability in darkreader, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-92706 in the wild and no public exploit code.\n\nAffected product: darkreader. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-92706/ (Markdown: https://insights.sbomify.com/CVE-2026-92706/index.md)","id":"CVE-2026-92706","markdown":"https://insights.sbomify.com/CVE-2026-92706/index.md","name":"CVE-2026-92706","record":{"aliases":["GHSA-jh5x-rphw-x532"],"analysis":{"component_type":"browser","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Dark Reader extension","requires_auth":"none","summary":"A malicious website can trigger the Dark Reader extension to request local resources, potentially disclosing limited information from local web servers.","user_interaction":"required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":3.4,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-668","name":"Exposure of Resource to Wrong Sphere"},{"id":"CWE-346","name":"Origin Validation Error"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Dark Reader is an accessibility browser extension that makes web pages colors dark. Prior to 4.9.126, a website can cause the browser extension's image inversion pipeline to request an unauthenticated icon-like bitmap from a locally running web server when the resource uses a known public-like HTTPS URL and is detected as requiring inversion. This behavior can cross the website-to-local-network boundary and disclose limited information associated with the requested resource. The darkreader npm package used for website integration is not affected. This issue is fixed in version 4.9.126 for Firefox and version 4.9.128 for other browsers.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Dark Reader: Ability to request icon-like bitmap data from certain local web servers","id":"CVE-2026-92706","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"MessagePack: Nested arrays can blow past buffer length limits","id":"CVE-2026-92707"},"packages":[],"prev":{"headline":"Aegisub executes arbitrary code through automatically loaded Automation scripts","id":"CVE-2026-92705"},"products":["darkreader"],"published":"2026-09-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-22","vendors":["darkreader"]},"summary":"A malicious website can trigger the Dark Reader extension to request local resources, potentially disclosing limited information from local web servers.","url":"https://insights.sbomify.com/CVE-2026-92706/"}