# CVE-2026-92706: Dark Reader: Ability to request icon-like bitmap data from certain local web servers

> A malicious website can trigger the Dark Reader extension to request local resources, potentially disclosing limited information from local web servers.

- **Severity:** Low 3.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 22 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-jh5x-rphw-x532

## What is CVE-2026-92706?

CVE-2026-92706 is a low-severity server-side request forgery vulnerability in darkreader, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Dark Reader is an accessibility browser extension that makes web pages colors dark. Prior to 4.9.126, a website can cause the browser extension's image inversion pipeline to request an unauthenticated icon-like bitmap from a locally running web server when the resource uses a known public-like HTTPS URL and is detected as requiring inversion. This behavior can cross the website-to-local-network boundary and disclose limited information associated with the requested resource. The darkreader npm package used for website integration is not affected. This issue is fixed in version 4.9.126 for Firefox and version 4.9.128 for other browsers.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere), CWE-346 (Origin Validation Error), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-92706?


## How do I fix CVE-2026-92706?

No fix has been published for CVE-2026-92706 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-92706 being exploited?

There is no known exploitation of CVE-2026-92706 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92706 and fix it if it is affected.

What it is: CVE-2026-92706 is a low-severity server-side request forgery vulnerability in darkreader, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-92706 in the wild and no public exploit code.

Affected product: darkreader. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92706/ (Markdown: https://insights.sbomify.com/CVE-2026-92706/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92706
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92706
- OSV: https://osv.dev/vulnerability/CVE-2026-92706

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92706/
Summaries are generated and may contain mistakes; the official description above is the record.
