# CVE-2026-92708: devalue: Cross-request process memory disclosure in devalue when `stringify` / `uneval` serialize Node Buffers

> Attackers can read sensitive process memory, including other users' data, by triggering serialization of Node Buffers in SvelteKit or Nuxt applications.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** CLSA-2026-1790888210, CLSA-2026-1790937656, CLSA-2026-1790965180, GHSA-j22f-vq7h-c4qm

## What is CVE-2026-92708?

CVE-2026-92708 is a high-severity vulnerability in sveltejs devalue, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. In versions 5.1.0 through 5.9.2, stringify and uneval functions serialize a typed array by emitting its entire backing ArrayBuffer rather than only the view, so serializing a Node Buffer, whose backing store is a process-wide shared pool, discloses up to 64 KB of unrelated process memory, including bytes from other in-flight requests. In a server-side-rendered framework such as SvelteKit or Nuxt, a public page whose load() returns a small Buffer, or that reads a small file, can therefore ship another user's request body or Authorization header in its HTML without authentication. Because this occurs during serialization, it fires on every such render and is not mitigated by the parse/unflatten prototype-pollution and denial-of-service guards, which only apply when parsing untrusted input. As a workaround, convert Node Buffer objects to Uint8Array before serialization. This issue has been fixed in version 5.9.3.

Weakness: CWE-226 (Sensitive Information in Resource Not Removed Before Reuse), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-92708?

2 open source packages ship an affected version, including devalue.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `devalue` | npm | From 5.1.0 | 5.9.3 |
| `devalue` | npm | From 5.1.0 | 5.9.3 |

## How do I fix CVE-2026-92708?

Upgrade devalue to 5.9.3 or later.

## Is CVE-2026-92708 being exploited?

There is no known exploitation of CVE-2026-92708 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92708 and fix it if it is affected.

What it is: CVE-2026-92708 is a high-severity vulnerability in sveltejs devalue, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-92708 in the wild and no public exploit code.

Affected packages and fixed versions:
- devalue (npm): affected from 5.1.0; fixed in 5.9.3
- devalue (npm): affected from 5.1.0; fixed in 5.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92708/ (Markdown: https://insights.sbomify.com/CVE-2026-92708/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92708
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92708
- OSV: https://osv.dev/vulnerability/CVE-2026-92708

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92708/
Summaries are generated and may contain mistakes; the official description above is the record.
