# CVE-2026-92834: Apache Thrift: C++ WebSocket server transport does not read a full request length

> Apache Thrift C++ WebSocket server fails to read full request length, potentially causing status code errors or uninitialized resource usage.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Oct 2026
- **Updated:** 2 Oct 2026
- **Also known as:** AZL-105422, BIT-thrift-2026-92834, DEBIAN-CVE-2026-92834, ECHO-a236-cb53-7fc3, GHSA-gcvr-924v-m58r, MINI-wp9h-xm4f-5g5r, UBUNTU-CVE-2026-92834

## What is CVE-2026-92834?

CVE-2026-92834 is a medium-severity vulnerability in Apache Thrift, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Use of uninitialized resource, Return of wrong status code vulnerability in Apache Thrift C++ WebSocket server.

This issue affects Apache Thrift: before 0.25.0.

Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Weakness: CWE-908 (Use of Uninitialized Resource), CWE-393 (Return of Wrong Status Code)

## Which versions are affected by CVE-2026-92834?

1 open source package ship an affected version, including thrift.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thrift` | Bitnami | All versions | 0.25.0 |

## How do I fix CVE-2026-92834?

Upgrade thrift to 0.25.0 or later.

## Is CVE-2026-92834 being exploited?

There is no known exploitation of CVE-2026-92834 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92834 and fix it if it is affected.

What it is: CVE-2026-92834 is a medium-severity vulnerability in Apache Thrift, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-92834 in the wild and no public exploit code.

Affected packages and fixed versions:
- thrift (Bitnami): affected all versions; fixed in 0.25.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92834/ (Markdown: https://insights.sbomify.com/CVE-2026-92834/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92834
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92834
- OSV: https://osv.dev/vulnerability/CVE-2026-92834

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92834/
Summaries are generated and may contain mistakes; the official description above is the record.
