CVE-2026-92874 Incorrect Authorization in GitLab

Medium 5.4 Published Updated

Authenticated users with MCP-scoped tokens could perform unauthorized actions due to improper authorization checks in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-92874?

CVE-2026-92874 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 23 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.3 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 that under certain conditions could have allowed an authenticated user with an MCP-scoped token to perform actions beyond the intended scope of that token due to improper authorization checks.

Weakness: CWE-863

Which versions are affected by CVE-2026-92874?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.3.019.2.7, 19.3.3, 19.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2026-92874?

Upgrade gitlab to a fixed version for your release line: 19.2.7, 19.3.3 or 19.4.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-92874 being exploited?

There is no known exploitation of CVE-2026-92874 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2026-92874, GHSA-c3rm-3hqr-4qwm, MINI-2286-q96g-fqcm, MINI-2gjq-h7cw-9x3p, MINI-3432-rfg6-pgrq, MINI-3479-25xw-6h5g and 45 more.

Is CVE-2026-92874 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free