# CVE-2026-9291: Insecure Deserialization in Amazon Braket SDK Job Results Processing

> Remote authenticated users with S3 write access can achieve arbitrary code execution via insecure deserialization in Amazon Braket SDK job results processing.

- **Severity:** High 7.5 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 May 2026
- **Updated:** 22 May 2026
- **Also known as:** GHSA-g697-2xrc-gc46, PYSEC-2026-2342

## What is CVE-2026-9291?

CVE-2026-9291 is a high-severity unsafe deserialization vulnerability in AWS Amazon Braket Python SDK, published on 22 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Insecure deserialization in the job results processing component in Amazon Braket SDK before 1.117.0 might allow a remote authenticated user with S3 write access to the job output bucket to achieve arbitrary code execution on any machine that processes job results.

We recommend you upgrade to amazon-braket-sdk version 1.117.0 or later.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-9291?

3 open source packages ship an affected version, including amazon-braket-sdk.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `amazon-braket-sdk` | PyPI | From 1.10.0 | 1.117.0 |
| `amazon-braket-sdk` | PyPI | From 1.10.0 | 1.117.0 |
| `amazon-braket-sdk` | PyPI | From 1.10.0 | 1.117.0 |

## How do I fix CVE-2026-9291?

Upgrade amazon-braket-sdk to 1.117.0 or later.

## Is CVE-2026-9291 being exploited?

There is no known exploitation of CVE-2026-9291 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9291 and fix it if it is affected.

What it is: CVE-2026-9291 is a high-severity unsafe deserialization vulnerability in AWS Amazon Braket Python SDK, published on 22 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-9291 in the wild and no public exploit code.

Affected packages and fixed versions:
- amazon-braket-sdk (PyPI): affected from 1.10.0; fixed in 1.117.0
- amazon-braket-sdk (PyPI): affected from 1.10.0; fixed in 1.117.0
- amazon-braket-sdk (PyPI): affected from 1.10.0; fixed in 1.117.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9291/ (Markdown: https://insights.sbomify.com/CVE-2026-9291/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9291
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9291
- OSV: https://osv.dev/vulnerability/CVE-2026-9291

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9291/
Summaries are generated and may contain mistakes; the official description above is the record.
