CVE-2026-92917 Grav 2.0.0-rc.1 through 2.0.21 Configuration Disclosure via print_r

High 8.7 Published Updated

Authenticated users with page-edit rights can expose sensitive configuration data, including credentials and API tokens, via Twig filters.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-92917?

CVE-2026-92917 is a high-severity vulnerability in getgrav grav, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Grav is a flat-file CMS. In versions 2.0.0-rc.1 through 2.0.21, the Twig content sandbox fails to restrict the dump and serialize filters (print_r, vardump, json_encode, yaml_encode, string): GravExtension::assertSandboxDumpSafe() determines sandbox state by calling SandboxExtension::isSandboxed() without a Source argument, which reports only the global sandbox flag that Grav never enables, so the guard added in GHSA-mc5q-6hpj-rp7j never executes. As a result, an authenticated user with page-edit rights can render {{ config|print_r }} in page content with Twig processing enabled and dump Grav's entire merged configuration — print_r reflects the real Config object held in a private property of the SandboxConfig facade, bypassing its path redaction — exposing plugin secrets such as SMTP credentials, API tokens, webhook secrets and cache backend passwords. Grav 1.7 is not affected because it ships no Twig content sandbox. The issue is fixed in 2.0.22, where the affected filters are registered with Twig's needs_is_sandboxed flag.

Weakness: CWE-200

Which versions are affected by CVE-2026-92917?

How do I fix CVE-2026-92917?

No fix has been published for CVE-2026-92917 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-92917 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92917 exists.

Sources

Also known as GHSA-rfr9-7h4p-gx2x, GHSA-rv7g-323x-h2q2.

Is CVE-2026-92917 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free