# CVE-2026-92917: Grav 2.0.0-rc.1 through 2.0.21 Configuration Disclosure via print_r

> Authenticated users with page-edit rights can expose sensitive configuration data, including credentials and API tokens, via Twig filters.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Sep 2026
- **Updated:** 19 Sep 2026
- **Also known as:** GHSA-rfr9-7h4p-gx2x, GHSA-rv7g-323x-h2q2

## What is CVE-2026-92917?

CVE-2026-92917 is a high-severity vulnerability in getgrav grav, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Grav is a flat-file CMS. In versions 2.0.0-rc.1 through 2.0.21, the Twig content sandbox fails to restrict the dump and serialize filters (print_r, vardump, json_encode, yaml_encode, string): GravExtension::assertSandboxDumpSafe() determines sandbox state by calling SandboxExtension::isSandboxed() without a Source argument, which reports only the global sandbox flag that Grav never enables, so the guard added in GHSA-mc5q-6hpj-rp7j never executes. As a result, an authenticated user with page-edit rights can render {{ config|print_r }} in page content with Twig processing enabled and dump Grav's entire merged configuration — print_r reflects the real Config object held in a private property of the SandboxConfig facade, bypassing its path redaction — exposing plugin secrets such as SMTP credentials, API tokens, webhook secrets and cache backend passwords. Grav 1.7 is not affected because it ships no Twig content sandbox. The issue is fixed in 2.0.22, where the affected filters are registered with Twig's needs_is_sandboxed flag.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-92917?


## How do I fix CVE-2026-92917?

No fix has been published for CVE-2026-92917 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-92917 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92917 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92917 and fix it if it is affected.

What it is: CVE-2026-92917 is a high-severity vulnerability in getgrav grav, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92917 exists.

Affected product: getgrav grav. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92917/ (Markdown: https://insights.sbomify.com/CVE-2026-92917/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92917
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92917
- OSV: https://osv.dev/vulnerability/CVE-2026-92917

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92917/
Summaries are generated and may contain mistakes; the official description above is the record.
