# CVE-2026-92933: vm2 before 3.11.8 Information Disclosure via util.getCallSites

> Sandboxed code can access host call stacks via util.getCallSites, leaking file paths and internal details.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 19 Sep 2026
- **Also known as:** ECHO-52f4-e7b3-c993, GHSA-r273-hxvj-fxhp, MINI-vqrq-2hjj-jwwq

## What is CVE-2026-92933?

CVE-2026-92933 is a medium-severity vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 is a sandbox for running untrusted Node.js code. In versions <= 3.11.7, NodeVM exposes the host `util` module to the sandbox as an unfiltered shallow copy (`Object.assign({}, util)` in `defaultBuiltinLoaderUtil`), and the deprecated `sys` builtin (an alias of host `util`) is exposed through the generic builtin loader. On Node.js >= 22.9 this hands sandboxed code `util.getCallSites()`, a programmatic stack-introspection API that returns the host process's full call stack, including absolute file paths, function names, and line numbers for vm2 bridge internals and the embedding application's entrypoint. This bypasses the host-frame redaction introduced for GHSA-v27g-jcqj-v8rw, which only applies to the `Error.prepareStackTrace` formatting channel. The issue is fixed in vm2 3.11.8.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-92933?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.11.8 |
| `vm2` | npm | All versions | 3.11.8 |

## How do I fix CVE-2026-92933?

Upgrade vm2 to 3.11.8 or later.

## Is CVE-2026-92933 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92933 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92933 and fix it if it is affected.

What it is: CVE-2026-92933 is a medium-severity vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92933 exists.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.11.8
- vm2 (npm): affected all versions; fixed in 3.11.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92933/ (Markdown: https://insights.sbomify.com/CVE-2026-92933/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92933
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92933
- OSV: https://osv.dev/vulnerability/CVE-2026-92933

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92933/
Summaries are generated and may contain mistakes; the official description above is the record.
