{"answers":{"affected":"2 open source packages ship an affected version, including vm2.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92934 exists.","fix":"Upgrade vm2 to 3.11.8 or later.","what":"CVE-2026-92934 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-92934 and fix it if it is affected.\n\nWhat it is: CVE-2026-92934 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92934 exists.\n\nAffected packages and fixed versions:\n- vm2 (npm): affected all versions; fixed in 3.11.8\n- vm2 (npm): affected all versions; fixed in 3.11.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-92934/ (Markdown: https://insights.sbomify.com/CVE-2026-92934/index.md)","id":"CVE-2026-92934","markdown":"https://insights.sbomify.com/CVE-2026-92934/index.md","name":"CVE-2026-92934","record":{"aliases":["CLEANSTART-2026-ZC70101","ECHO-fee7-cbd6-d0aa","GHSA-x965-fc75-jpqh","MINI-ccqw-8399-6rh9","ROOT-APP-NPM-CVE-2026-92934"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript sandbox library","requires_auth":"none","summary":"Attackers can escape the vm2 sandbox to execute arbitrary code and disclose process information by exploiting a flaw in AggregateError handling.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":9.5,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-693","name":"Protection Mechanism Failure"}],"description":"vm2 before 3.11.8 contains an incomplete fix for Error.cause sanitization that allows sandbox escape when revisited host-wrapped AggregateError objects are caught within a single exception handler traversal. Attackers can exploit cycle detection bypass in handleException to access unsanitized host proxies embedded in the errors array, enabling full remote code execution and process information disclosure from the sandbox.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"vm2 before 3.11.8 Sandbox Escape RCE via AggregateError","id":"CVE-2026-92934","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"vm2 NodeVM Remote Code Execution via Array-Shaped Require","id":"CVE-2026-92935"},"packages":[{"ecosystem":"npm","fixed":["3.11.8"],"introduced":["0"],"last_affected":[],"package":"vm2","purl":null,"source":"GHSA-x965-fc75-jpqh"},{"ecosystem":"npm","fixed":["3.11.8"],"introduced":["0"],"last_affected":[],"package":"vm2","purl":"pkg:npm/vm2","source":"GHSA-x965-fc75-jpqh"}],"prev":{"headline":"vm2 before 3.11.8 Information Disclosure via util.getCallSites","id":"CVE-2026-92933"},"products":["vm2"],"published":"2026-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-17","vendors":["patriksimek"]},"summary":"Attackers can escape the vm2 sandbox to execute arbitrary code and disclose process information by exploiting a flaw in AggregateError handling.","url":"https://insights.sbomify.com/CVE-2026-92934/"}