# CVE-2026-92934: vm2 before 3.11.8 Sandbox Escape RCE via AggregateError

> Attackers can escape the vm2 sandbox to execute arbitrary code and disclose process information by exploiting a flaw in AggregateError handling.

- **Severity:** Critical 9.5 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** CLEANSTART-2026-ZC70101, ECHO-fee7-cbd6-d0aa, GHSA-x965-fc75-jpqh, MINI-ccqw-8399-6rh9, ROOT-APP-NPM-CVE-2026-92934

## What is CVE-2026-92934?

CVE-2026-92934 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 before 3.11.8 contains an incomplete fix for Error.cause sanitization that allows sandbox escape when revisited host-wrapped AggregateError objects are caught within a single exception handler traversal. Attackers can exploit cycle detection bypass in handleException to access unsanitized host proxies embedded in the errors array, enabling full remote code execution and process information disclosure from the sandbox.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-92934?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.11.8 |
| `vm2` | npm | All versions | 3.11.8 |

## How do I fix CVE-2026-92934?

Upgrade vm2 to 3.11.8 or later.

## Is CVE-2026-92934 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92934 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92934 and fix it if it is affected.

What it is: CVE-2026-92934 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-92934 exists.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.11.8
- vm2 (npm): affected all versions; fixed in 3.11.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92934/ (Markdown: https://insights.sbomify.com/CVE-2026-92934/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92934
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92934
- OSV: https://osv.dev/vulnerability/CVE-2026-92934

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92934/
Summaries are generated and may contain mistakes; the official description above is the record.
