CVE-2026-92935 vm2 NodeVM Remote Code Execution via Array-Shaped Require
Attackers can escape the vm2 sandbox and execute arbitrary code on the host if the NodeVM is configured with nesting enabled and an array-shaped require option.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-92935?
CVE-2026-92935 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
vm2 is a sandbox for running untrusted Node.js code. In versions >= 3.11.4 and <= 3.11.6, the NodeVM constructor computes `hasRealRequireConfig` with `typeof requireOpts === 'object' && requireOpts !== null`, so an array-shaped `require` value (for example `require: []`) satisfies the guard that is meant to reject nesting without an explicit require configuration. `makeResolverFromLegacyOptions()` then destructures the array into undefined option fields and returns a resolver containing only `NESTING_OVERRIDE.vm2`. As a result, an attacker who can supply JavaScript executed by a NodeVM configured with truthy `nesting` and an array-shaped `require` (e.g. `new NodeVM({nesting: true, require: []})`) can require the host `vm2` module, create an inner NodeVM with an attacker-chosen builtin allowlist (such as `child_process`), and execute arbitrary commands with the privileges of the host Node.js process, escaping the sandbox. Outer builtin restrictions do not constrain the attacker-created inner NodeVM. This issue is fixed in vm2 3.11.7.
Weakness: CWE-913
Which versions are affected by CVE-2026-92935?
2 open source packages ship an affected version, including vm2.
| Package | Affected | Fixed in |
|---|---|---|
vm2 npm | From 3.11.4 | 3.11.7 |
vm2 npm | From 3.11.4 | 3.11.7 |
How do I fix CVE-2026-92935?
Upgrade vm2 to 3.11.7 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-92935 being exploited?
There is no known exploitation of CVE-2026-92935 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as CLEANSTART-2026-RL65509, ECHO-023c-6b50-66b5, GHSA-8hr7-r645-pc6w, MINI-3j45-rr8g-j99g, ROOT-APP-NPM-CVE-2026-92935.