{"answers":{"affected":"2 open source packages ship an affected version, including vm2.","exploited":"There is no known exploitation of CVE-2026-92935 in the wild and no public exploit code.","fix":"Upgrade vm2 to 3.11.7 or later.","what":"CVE-2026-92935 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-92935 and fix it if it is affected.\n\nWhat it is: CVE-2026-92935 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-92935 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vm2 (npm): affected from 3.11.4; fixed in 3.11.7\n- vm2 (npm): affected from 3.11.4; fixed in 3.11.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-92935/ (Markdown: https://insights.sbomify.com/CVE-2026-92935/index.md)","id":"CVE-2026-92935","markdown":"https://insights.sbomify.com/CVE-2026-92935/index.md","name":"CVE-2026-92935","record":{"aliases":["CLEANSTART-2026-RL65509","ECHO-023c-6b50-66b5","GHSA-8hr7-r645-pc6w","MINI-3j45-rr8g-j99g","ROOT-APP-NPM-CVE-2026-92935"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js sandbox library","requires_auth":"none","summary":"Attackers can escape the vm2 sandbox and execute arbitrary code on the host if the NodeVM is configured with nesting enabled and an array-shaped require option.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":9.5,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-913","name":"Improper Control of Dynamically-Managed Code Resources"}],"description":"vm2 is a sandbox for running untrusted Node.js code. In versions \u003e= 3.11.4 and \u003c= 3.11.6, the NodeVM constructor computes `hasRealRequireConfig` with `typeof requireOpts === 'object' \u0026\u0026 requireOpts !== null`, so an array-shaped `require` value (for example `require: []`) satisfies the guard that is meant to reject nesting without an explicit require configuration. `makeResolverFromLegacyOptions()` then destructures the array into undefined option fields and returns a resolver containing only `NESTING_OVERRIDE.vm2`. As a result, an attacker who can supply JavaScript executed by a NodeVM configured with truthy `nesting` and an array-shaped `require` (e.g. `new NodeVM({nesting: true, require: []})`) can require the host `vm2` module, create an inner NodeVM with an attacker-chosen builtin allowlist (such as `child_process`), and execute arbitrary commands with the privileges of the host Node.js process, escaping the sandbox. Outer builtin restrictions do not constrain the attacker-created inner NodeVM. This issue is fixed in vm2 3.11.7.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2026-10-23","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-10-23T23:37:45Z","kind":"github_poc","ref":"https://github.com/CompleteTech-Security/vm2-nesting-check","stars":0,"title":"Offline vm2 evidence checker for CVE-2026-92935. Sandbox package and nesting evidence. Standalone Python; JSON/CSV/HTML reports; no exploit payloads."}],"tier":"poc_unverified"},"has_fix":true,"headline":"vm2 NodeVM Remote Code Execution via Array-Shaped Require","id":"CVE-2026-92935","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"vm2 3.11.0 before 3.11.7 Information Disclosure via Error Stack","id":"CVE-2026-92936"},"packages":[{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["3.11.4"],"last_affected":[],"package":"vm2","purl":null,"source":"GHSA-8hr7-r645-pc6w"},{"ecosystem":"npm","fixed":["3.11.7"],"introduced":["3.11.4"],"last_affected":[],"package":"vm2","purl":"pkg:npm/vm2","source":"GHSA-8hr7-r645-pc6w"}],"prev":{"headline":"vm2 before 3.11.8 Sandbox Escape RCE via AggregateError","id":"CVE-2026-92934"},"products":["vm2"],"published":"2026-09-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-17","vendors":["patriksimek"]},"summary":"Attackers can escape the vm2 sandbox and execute arbitrary code on the host if the NodeVM is configured with nesting enabled and an array-shaped require option.","url":"https://insights.sbomify.com/CVE-2026-92935/"}