# CVE-2026-92935: vm2 NodeVM Remote Code Execution via Array-Shaped Require

> Attackers can escape the vm2 sandbox and execute arbitrary code on the host if the NodeVM is configured with nesting enabled and an array-shaped require option.

- **Severity:** Critical 9.5 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** CLEANSTART-2026-RL65509, ECHO-023c-6b50-66b5, GHSA-8hr7-r645-pc6w, MINI-3j45-rr8g-j99g, ROOT-APP-NPM-CVE-2026-92935

## What is CVE-2026-92935?

CVE-2026-92935 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 is a sandbox for running untrusted Node.js code. In versions >= 3.11.4 and <= 3.11.6, the NodeVM constructor computes `hasRealRequireConfig` with `typeof requireOpts === 'object' && requireOpts !== null`, so an array-shaped `require` value (for example `require: []`) satisfies the guard that is meant to reject nesting without an explicit require configuration. `makeResolverFromLegacyOptions()` then destructures the array into undefined option fields and returns a resolver containing only `NESTING_OVERRIDE.vm2`. As a result, an attacker who can supply JavaScript executed by a NodeVM configured with truthy `nesting` and an array-shaped `require` (e.g. `new NodeVM({nesting: true, require: []})`) can require the host `vm2` module, create an inner NodeVM with an attacker-chosen builtin allowlist (such as `child_process`), and execute arbitrary commands with the privileges of the host Node.js process, escaping the sandbox. Outer builtin restrictions do not constrain the attacker-created inner NodeVM. This issue is fixed in vm2 3.11.7.

Weakness: CWE-913 (Improper Control of Dynamically-Managed Code Resources)

## Which versions are affected by CVE-2026-92935?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | From 3.11.4 | 3.11.7 |
| `vm2` | npm | From 3.11.4 | 3.11.7 |

## How do I fix CVE-2026-92935?

Upgrade vm2 to 3.11.7 or later.

## Is CVE-2026-92935 being exploited?

There is no known exploitation of CVE-2026-92935 in the wild and no public exploit code.

Public exploit code:

- Offline vm2 evidence checker for CVE-2026-92935. Sandbox package and nesting evidence. Standalone Python; JSON/CSV/HTML reports; no exploit payloads. (github_poc): https://github.com/CompleteTech-Security/vm2-nesting-check

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-92935 and fix it if it is affected.

What it is: CVE-2026-92935 is a critical code injection vulnerability in patriksimek vm2, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-92935 in the wild and no public exploit code.

Affected packages and fixed versions:
- vm2 (npm): affected from 3.11.4; fixed in 3.11.7
- vm2 (npm): affected from 3.11.4; fixed in 3.11.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-92935/ (Markdown: https://insights.sbomify.com/CVE-2026-92935/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-92935
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-92935
- OSV: https://osv.dev/vulnerability/CVE-2026-92935

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-92935/
Summaries are generated and may contain mistakes; the official description above is the record.
